Forum Électro-Bidouilleur

Merci de vous connecter ou de vous inscrire.

Connexion avec identifiant, mot de passe et durée de la session
Recherche avancée  

Nouvelles:

Bienvenue au nouveau Forum Électro-Bidouilleur! Inscrivez-vous pour participer aux discussions! L'inscription est automatisée.

Voir les contributions

Cette section vous permet de consulter les contributions (messages, sujets et fichiers joints) d'un utilisateur. Vous ne pourrez voir que les contributions des zones auxquelles vous avez accès.

Messages - Yffig

Pages: [1] 2 3 ... 5
1
Bonsoir Cécile,
Le choix du TIP41C est un bon choix mais je suis surpris du prix chez nombre de distributeurs...
Originellement, ce TO220-like est apparu dans les années 70 chez Texas Instruments comme son nom l'indique et puis TI a certainement dû abandonner le process et ne le fait plus. On le trouve chez ON, ST, et autres.
J'avais acheté un lot de ST micro sur eBay (plus son cousin PNP TIP42C) en Thailande à ~030€ pièce chez ThaiShop ETC, aujourd'hui disparu.
Les Allemands de Reichelt ont une seconde source à 0.27€ pièce.. et il y a plein de vendeurs AliExpress à prix fracassés .
Farnell a une 2nde source Multicomp un peu chère (1.46€ à l'unité).

Juste un petit détail: la datasheet ON semi a un bug...
Ils donnent une Rth-jc de 1.67°C/W alors qu'elle est de 1.92°C/W (confirmé par la DS de Multicom chez Farnell) et par le calcul du Power Derate above 25°C de ON (=0.52W/°C):
A 70°C, tu auras donc 65W-0.52*(70°-25°)= 41.6W, qui matche bien avec ton estimation de 40W. Ca roule !
A plus !
Yffig

2
Bonsoir Cécile,
Je t'avais promis de développer les aspects Puissance dissipée dans le transistor ballast d'une alim linéaire et sécurité de fonctionnement de la pauvre puce stressée.
Je commence par le cas d'un unique transistor ballast: un 2SD1047, celui de l'alim chinoise...

Je fais ici référence à la datasheet ST Micro d'un 2SD1047.
@ page2- Electrical Ratings Table2, on y trouve:
 -Ptot à Tc (c=case=boîtier)=25°C => 100W (max), c'est bien sûr Pd=Vce*Ic que le transistor dissipe... à condition que son boîtier (case) soit maintenu à 25°C et pas plus !
- Tj (j=junction) = 150°C (max).
On en déduit facilement que, si la température du boîtier est maintenue à 25°C et que le transistor dissipe Pd= Vce*Ic = Ptot = 100W,  c'est que la résistance thermique du D1047 entre jonction et boîtier vaut : (150°-25°)/100W = 1.25°C/W (ou plus rigoureusement 1.25 Kelvin par Watt). C'est bien ce que donne la table 3: Rth j-case =1.25°C/W.
Jusque là pas de pb, l'alim est donnée pour 30V*3A=90W...
Sauf que c'est SI LE BOITIER EST MAINTENU à 25°C... et UNIQUEMENT DANS CE CAS.
Donc il faut ABSOLUMENT maintenir le boîtier à 25°C pour pouvoir tirer 100W de ce transistor, OR
- la température ambiante est souvent supérieure à 25°C => mettre l'alim au frigo ? ;)
- et même si cette condition Tambiante <= 25°C est respectée, la différence de température entre boitier et ambiance est directement dépendante du radiateur utilisé (et de sa ventilation par convection ou forcée par ventilo).
Il est donc en pratique impossible, sauf radiateur de taille infinie ou refroidi par eau de source, effet Peltier, azote liquide .. ;) , de satisfaire à la condition Tcase max =25°C sous nos latitudes...

Suppose alors que tu arrives à maintenir la temp du boîtier à 50°C ou 80°C grace à un très bon ou correct "radiateur":
-A 50°, Tj max = 150° => le delta T entre jonction et boîtier sera de 100°. Avec une Rth de 1.25°C/W pour le D1047, la puissance max que pourra supporter le transistor sera de 100 (°C)/1.25 (°/W) =  80 W
-A 80°, Tj max = 150° => le delta T entre jonction et boîtier sera de 70°. Avec une Rth de 1.25°C/W pour le D1047, la puissance max que pourra supporter le transistor sera de 70 (°C)/1.25 (°/W) =  56 W

Quand cette alim chinoise est mise en court circuit (avec sa limitation CC au max), le transistor va devoir dissiper Vce*Ic:
-Vce est alors en moyenne de 27.6V ( pour Vpeak= 30v et C filtrage de 3000µF) (valeur fournie par LTSpice)
-Ic ~ 3A
soit ~82.8W.
Le radiateur prévu pour 50°C max est plus que limite, celui qui est calculé pour 80° fera fondre le transistor dans la seconde qui suit.

Voilà donc une première approche de la problématique. Ce n'est même pas la peine d'aborder la figure 2 de la datasheet (Safe Operating Area) car la courbe DC Operation du graphique est forcément celle de Tc=25°C, totalement irréaliste...
Donc, quand tu auras fait ton choix de transistor ballast (et du nombre de ceux ci), refais ces calculs très simples et tu sauras très vite si ça va tenir le choc (ou pas !).
Si tu te contentes de 20V et 2A soit 40W en court circuit, avec un système de dissipateur qui t'assure moins de 80°C au boîtier, ce transistor D1047 suffit.

Bonne lecture

PS: il faudra aussi que je revienne sur ta vision du mode CC, ce n'est pas une source de courant constant, c'est une limitation réglable du courant max que va délivrer ton alim.. ça peut vraiment servir même si ça met du temps à réagir (mais le mode CV aussi  ;) ).

Yffig

3
Bonsoir Cécile,
Je regardais le schéma de ta simulation sous LTSpice , sans doute avec la XVII puisqu'il y a un ADA4522-1 qui n'existe pas dans la version IV, tout du moins dans la 4.23i que j'utilise.
On trouve aussi dans ta simulation les 2 BJT suivants: TIP41C et BD139 non disponibles en \lib\cmp\standard.bjt de la XVII ... C'est donc que tu as trouvé leurs modèles Spice sur le net et que tu les as importé dans la version XVII, non ?
Tu progresses bien  8)
Je suppose que tu as ajouté les .model de ces 2 BJT dans standard.bjt, non ?
Je ne sais pas encore comment fait la XVII que je viens d'installer mais en ce qui concerne la IV, chaque update de LTSpice écrasait les .model que j'avais ajoutés dans cette bibliothèque standard.bjt. Pour éviter cette galère, j'ai créé des fichiers texte pour conserver ces importations (par exemple pour les BJT, j'ai un fichier BJT.lib dans \lib\sub où je mets tous les .model que j'ai récupérés) et dans mon .asc, j'ajoute la directive Spice suivante:  .include bjt.lib. J'ai fait idem pour les diodes et les Jfet.
Pour des composants plus sophistiqués (MOSFet et Puces), il faut passer par les subcircuits et la bibliothèque personnalisée \AutoGenerated ce que je n'ai pas encore testé sur la XVII mais je vais le faire et je te dirais si c'est OK...à moins que tu ne sois suffisamment avancée pour l'avoir déjà fait  ;)

Un détail sur ta simulation: tu as conservé R9 à 0.1R...La valeur à y mettre dépend de la résistance de ton transfo en particulier, je l'avais mise à 0.1 pour ne pas oublier qu'elle existe mais elle est à mesurer ou estimer.

Bonne soirée
Yffig



4
Bonjour Cécile,
J'espère que tu as pu accéder au doc dont je t'ai transmis l'URL (c'est probable que tu sois alors plongée dedans...)

Je voulais juste te faire une remarque, je te cite:
"Une limite de courant à 100ms? mais c'est nul, non? Enfin, je veux faire mieux que ça, personnellement... C'est d'un lent, 100ms..."

Il te faut rester calme et humble  ;)
Je t'ai transmis l'expérience de Cyrob qui a constaté que la limitation de courant CC met au mieux 100ms pour être active sur grand nombre d'alims du commerce. Je t'ai déja signalé que si ces alim valent des dizaines et même des centaines d'euros, c'est pas pour t'arnaquer .
Si des équipes d'ingénieurs de R&D n'arrivent pas à faire mieux que 100 ms, N'IMAGINE PAS que TU FERAS MIEUX, NON !
Il y a une raison à cela: que tu sois en CV ou en CC, tu as toujours affaire à un asservissement = système bouclé dont tu dois assurer la stabilité sous toutes conditions (tu l'as même simulé et constaté que ça oscillait... en CV).
Pour ce faire, il est nécessaire de "couper la bande passante en boucle ouverte (BO) de l'asservissement assez tôt (en fréquence) pour que le gain en BO devienne < à 1 quand la phase en BO s'approche de 135°...180° (je ne sais pas si tu as acquis ces notions), ou autrement dit, il te faut créer un pôle de compensation suffisamment bas en fréquence pour respecter la condition (c'est le rôle du condensateur "intégrateur" en sortie de l'AmpOp et l'entré inverseuse).
C'est donc essentiellement pour cela que les alims linéaires ne sont pas des"foudres de guerre" en régime transistoire:
- en mode CV, tu vas améliorer cette réponse en transitoire avec un bon gros condo en sortie (bien que celui ci influe sur la réponse en BO...mais l'art de l'ingénieur c'est le compromis...)
- en mode CC, tu dois donc mieux comprendre pourquoi ça met 100 ms avant de réagir... et que ton courant délivré doit être limité par un autre moyen avant que CC ne soit active (c'est le rôle de LIMITE ULTIME) pour protéger tes transistors ballasts (cf l'alim chinoise de base qui crame son SD1047).

Autre point: C14 de ton schéma 1 (C5 de ta simulation)... Tu es sûre de toi ?
(NB: dans ton schéma 1, tu as même oublié de brancher le feedback de Vout sur l'entrée (-) !)

Et aussi, selon certains auteurs 50v en DC... ça commence à être potentiellement dangereux ! "'Tention à où tu mets tes mains

Bonne journée

5
Bonjour Cécile !
D'abord on espère tous que tes épreuves du bac se sont bien déroulées.
Je vais répondre rapidement à ta nouvelle mouture, sans pouvoir être exhaustif (y' a beaucoup à commenter), je vais donc me contenter de qq remarques initiales à partir du schéma Simu.png de LTSpice:
-Tu pars de 50V non régulés...Quand tu fais un court circuit (avec un courant limité uniquement par Q4 et R5) tu auras environ 0.6V/0.15= 4A soit environ 200W à dissiper dans tes 2 TIP41C sur radiateur AMD (? qu'est ce ? quelle taille , quelle résistance thermique ?) et même avec un ventilo...je te garantis que ça ne tiendra pas !
Très généralement tu auras souvent besoin de 5V, 3.3V, voire 12v et un fort courant soit une tension et donc une dissipation de plusieurs dizaines de W dans chaque transistor. Ca va pas le faire...
-Tu parles de bruit...N'est ce pas plutôt de "ripple" dont  il s'agit (en bon français de résiduelle 100 Hz) ?
- Les 100ms de temps de réponse de la partie CC que j'ai évoqués précédemment (en citant l'expérience de Cyrob pour confirmer mes propres tests) ne peuvent pas être mis en évidence par ta simulation puisque la partie CC n'y existe pas. Q4 et R5 ne sont pas une CC mais une PRECAUTION ULTIME. L'ensemble transistors ballast et Q4 forment en quelque sorte un unique composant dont le temps de réponse est très rapide et elle n'est pas la cause de l'oscillation que tu constates...
Cette oscillation (de la régulation de tension !) est liée à la très fragile stabilité de la boucle de régulation de tension, et encore, tu n'as pas chargé ta sortie avec un bon gros condo....(test obligatoire ! j'y mets à demeure un 1000µ !).
Cet aspect stabilité  de la régulation de tension (qui s'observe pas en sortie régulée mais DANS LA BOUCLE ELLE MEME, en sortie de l'AmpOp) est un sujet vraiment délicat et "touchy" qui ne se finalise que sur prototype.

Bref, ne t'emballe pas trop vite, il y a encore du boulot, en particulier sur les aspects puissance dissipée dans les ballasts, je pense que tu es largement sous dimensionnée; un TIP41C à une température de boîtier de 80°C ne peut même pas supporter 40W (cf Datasheet ON Semi fig.1 par ex.);

Bon courage.
Yffig


6
Bonjour,
Bien vu ta dernière proposition, Jean Louis !
Chaque diode protège l'autre en tension inverse.
Le courant me parait un peu fort (environ 25mA) et risque de masquer la présence d'une résistance en série. Quelques mA pourraient permettre de détecter une résistance série indésirable ou voulue par baisse nette de la luminosité de la Led: à ajuster donc.
Yffig

7
Bonjour Marmalou,
Merci pour tes remerciements.
C'est une petite bidouille réalisée il y a quelques années pour visualiser l'accord d'un démodulateur FM en quadrature et il y a avait  une alimentation variable à LM317 pour régler le niveau de la fenêtre d'accord (dans mon cas les 2 Leds devaient être allumées à l'accord et indiquer ensuite dans quel sens était le désaccord. C'était vraiment de la grosse  bidouille alambiquée car je n'avais pas de galvanomètre à 0 central (j'en ai trouvé ensuite sur eBay à Taiwan). Et pi, ça se décalait un poil avec la température.
J'ai pensé à ce détournement de porte logique pour faire de l'analogique rapidos pour ton besoin et je te l'ai décrit dans le détail car ça peut toujours aider mais je ne ferai pas ça à chaque question  ;)
Amuse toi bien !
Yffig

8
Erratum:
R4 fait 4.7K , pas 2.7K tel qu'indiqué sur le 2ème schéma.

9
Bonsoir  Marmadou,

Ce post va être un peu long mais comme tu as envie de savoir, le voici !

L'avantage (aujourd'hui) de la "vieille et bien lente" série de circuts logiques CMOS CD4000  est la possibilité de les alimenter de 3v à 15v (et même 18v pour certains fabricants).
Un panorama assez complet est donné par https://fr.wikipedia.org/wiki/Liste_des_circuits_int%C3%A9gr%C3%A9s_de_la_s%C3%A9rie_4000.
Un autre avantage est que, pour une tension d'alimentation Vcc donnée, les tensions de basculement des portes suivent la tension d'alimentation et sont toujours assez proches de Vcc/2 (sauf portes trigger de schmitt éventuellement).

Dans un premier test,
tu pourras monter sur breadboard le premier schéma qui va te permettre de voir les seuils de basculement des 2 portes A et B (comme le décrit la datasheet ON page 7, fig.10). La porte C permet ensuite d'inverser la sortie A afin d'avoir une Led qui retourne à la masse.
La variante [A+C et B] (qui sera celle du montage final) permet d'utiliser éventuellement des diodes LED bicolores à cathode commune reliée au 0v (Pour des LED à anode commune, c'est le montage B qu'il faut faire suivre d'une porte inverseuse C avec la LD connectée comme sur A).
L'alimentation des circuits est réglée à 14.8V (batterie auto bien chargée) mais tu peux aussi prendre 13.8V qui est la valeur classiquement utilisée.
Tu règles alors le potentiomètre 10 tours (en mesurant la tension sur ta pointe de touche) afin de mettre en évidence le basculement des 2 LEDs:
Sur MON(*) breadboard:
- la verte est allumée tant que la tension d'entrée V < VA = environ 8.06v, puis s'éteint. La rouge est éteinte.
- la rouge s'allume pour une tension d'entrée V > VB de l'ordre de 8.13v.La verte est toujours éteinte.
Entre ces deux tensions 8.06V et 8.13v les deux LED sont soit éteintes(*), soit dans un état erratique (scintillement car la tension d'entrée + bruit est à environ la moitié de la pente de la figure 10).
Tu as donc 3 zones avec des états différents:
- V < VA : Zone: Verte ON, Rouge Off
- VA < V < VB: Zone:  "indéterminée"... où les deux Leds sont plutôt éteintes (*)
- V > VB : Zone: Verte Off, Rouge ON
(*) Sur MON breadboard, si j'inverse les 2 portes A et B, la zone indéterminée devient une zone où les 2 leds sont plutôt allumées simultanément, c'est tout simplement lié au fait que les deux portes ne basculent pas pour exactement la même valeur de tension,  et tu pourrais avoir cet effet sur ton test (une chance sur deux...).

L'objectif de la version finale est alors de :
- Modifier VA et VB de manière à élargir la zone intermédiaire => diminuer VA et augmenter VB
- S'assurer que la zone indéterminée se transforme en une zone où les 2 LEDS seront éteintes, corollaire de l'objectif précédent.
Pour cela il suffit de passer VA à VA-(environ 2v) et VB à VB+(environ 2v): la LED verte sera allumée jusqu'à VA-2v et s'éteindra ensuite,la led rouge, initialement éteinte, va s'allumer pour VB+2V.
Entre VA-2v et VB+2V, les deux Leds seront alors éteintes.
Pour réaliser cela 2 leds (rouges) supplémentaires sont alimentées en permanence et décalent la tension présente sur la pointe de touche de + ou - environ 2 volts. Ces Leds n'ont pas besoin d'être visibles et seront avantageusement des 3mm pour des raisons d'encombrement. Quand la pointe de touche est en l'air, la tension présente sur cette touche sera d'environ Vcc/2 donc dans la zone leds éteintes.
Si tu souhaites un écart moins important que +/- 2V tu mets des diodes Silicium type 1N4148 (ca te fera +/-1.2v avec 2 * 2 diodes )
Note bien le croisement des entrées des portes par rapport au 1er schéma (ça permet de garder les mêmes portes et mêmes Led sur ton breadboard).
Une question intéressante est: quelle est la résistance maximale possible entre l'entrée de la sonde et la masse ou le +12V pour obtenir une réponse "positive" c'est la masse ou le +12v ?
La réponse est écrite sur le schéma 2 si tu utilises des Leds rouge. Test intéressant à faire par toi même avec des diodes Si et avec la solution diodes Zener de Jean Louis.
Pour info, le CI utilisé est un CD4011B de chez Harris Semiconductors (aujourd'hui TI) daté 9232 soit 27 ans...

Cordialement

Yffig


10
Bonsoir Marmalou,
Loulou31 devrait te répondre mais je me permet de te proposer 2 raisons au moins:
1- Lorsque tu touches la masse (par ex. puisque ton montage est symétrique et ce pourrait être le +14.8V de ta batterie bien chargée) une des branches va conduire donnant une tension au point de jonction entre tes deux zeners= 14.8v-2v (Vf de la LED) -6,2V de la zener ~ 6.6V. L'autre branche verra aussi ces 6.6v, or tu as une Zener qui chutera 6.2v si elle devait conduire et il te reste donc 0.4V en inverse sur la LED
=> c'est safe pour la LED dont les constructeurs donnent souvent une tension Vr max de 5V (En pratique je n'ai jamais vu une LED exploser si on lui met -5v en inverse mais bon c'est écrit comme ça dans les datasheets des LED...).

Si tu mettais des zeners de 3.3V la tension au point de jonction des 2 zeners serait alors de 9.5v. L'autre zener chuterait de 3.3v => ton autre LED verrait  6.2V en inverse ce que le constructeur "t'interdit"....
Dans ce cas la deuxième résistance de 200 de ton 1er schéma pourrait être utile...

2- Une autre raison est que les zeners de Vz de 5 à 7v ont le coude le plus "raide". Avec quelques unes de mes tiroirs:1N4728A-32A-34A-37a et 1N4738A  de respectivement 3.3v, 4.7v,5.6v, 7.5v et 8.2v (je n'ai pas de 6v2), j'ai mis sur le même graphique les courbes Iz(Vz) pour ces diodes tracées avec un petit Peak DCA75: les courbes parlent d'elle même.

PS: je te ferais schémas et explications pour demain soir

Yffig

11
La proposition de loulou31 me semble beaucoup plus simple et plus facile à implémenter.
Tu devrais alors la retenir, tiens moi au courant, cela m'évitera la charge de dessin et d'explications.
A Plus

Yffig

12
ReRe...
J'ai fini le test bread board: c'est OK !
Alimentation sur batterie de 14.8V que j'appelle le 15V mais c'est le + de la batterie bien sûr
Quand tu laisses l'entrée en l'air les 2 leds sont éteintes: c'est bien ce que tu voulais.
Quand tu touches la masse, la verte est allumée et le reste tant que la tension présente sur ta touche est inférieure à 6.03v*
Puis la verte s'éteint, la Rouge va s'allumer quand la tension sur la pointe de touche atteint 10.24v*
Autrement dit, tu as trois zone de fonctionnement:
-Led Verte allumée=> tu touches soit la masse soit un point relié à la masse par une résistance faible*; la rouge est éteinte
-La Led verte s'éteint quand ta pointe de touche rencontre une résistance plus élevée (par ex entrée en l'air) qui met ta pointe de touche à un peu plus de 6v, la Led rouge est toujours éteinte
-Lorsque ta pointe de touche voit une tension supérieure à 10.24V (donc que tu touches soit le +15v, soit une  résistance faible reliée au +15V ) la LED rouge va s'allumer (la verte est toujours éteinte).
*: la pointe de touche va débiter un courant ou consommer un courant MAX de 28 mA quand tu touches directement la masse ou directement le 15v. dès qu'une résistance est présente dans le circuit ce courant diminue.
Tu comprendras mieux sur le schéma et les explications qui vont venir d'ici dimanche soir.
Coût: 2 * résistances 2.7K, 2*résistances de 470, 3 Led rouges (dont 2 de 3mm si tu veux rester sous un petit volume) 1 Led verte, 1*CD4011B ou 4001B, un support 14 broches, j'y ajouterai volontiers un condo de découplage de 10nF entre pin +15v et 0v.

Si ta batterie est faible ou la température est élevée (proximité du moteur chaud, sonde laissée au soleil, chaleur de la paume de la main...) les valeurs des seuils seront quelque peu différents mais ça continuera à le faire.

Bon bricolage.

Yffig

13
Re...
J'ai mal écrit le nom du boitier c'est un CD4011B (pas CB4011B) et cela peut être aussi un CD4001B.
Les lettre CD viennent du fabricant initial de ces puces CMOS (c'était RCA je crois) mais tu les trouveras en MC1xxxx, HEFxxxx, etc
Le seul point important ce sont les 4 chiffres 4011/4001 terminés par un la lettre B (comme bufferisé et donc capable de plus de courant de sortie que sans le B...).
Une autre solution, si tu en as sous la main, serait sans doute le double comparateur LM393 en boitier plus petit, un autre bidouilleur pourrait te la proposer.
Bon week-end

Yffig

14
Bonjour Marmalou,
J'espère que jusque là tu suis parce que ça va se corser un peu...
En effet, page 3 d la datasheet tu as la dernière information dont tu as besoin: Input Voltage (tension d'entrée)
Tu es sur la ligne VDD Vdc =15 (Volts) et tu as deux infos: ce que le circuit va considérer comme une entrée de niveau logique 0 (Vil) et comme une entrée de niveau logique 1 (Vih):
Pour qu'une tension d'entrée soit considérée comme un niveau logique 0 ("0" Level), la datasheet te dis qu'il faut, à 15V et à 25°C,  typiquement moins de 6.75V, et même jusqu'à moins de 4V. Alors tu seras sûr que le niveau de sortie sera un niveau logique 1 (la porte est un circuit inverseur).
Inversement pour le niveau logique 1 ("1" Level), tu devras avoir plus que 8.25V typiquement mais pouvant aller jusqu'à 11V en entrée. Alors tu seras sûr que ton niveau de sortie sera un niveau logique 0 (circuit inverseur).
Ces dispersions dans les caractéristiques des circuits obligent donc à les prendre en compte si tu veux que ton circuit marche à tous les coups quel que soit le boitier CMOS que tu utilises.
Tu as 3  zones de niveau d'entrée:
De 0V à 4v...6.75V => Niveau considéré comme un 0
De 4...6.75V à 8.25V....11V selon le boîtier => Niveau d'entrée indéterminé pour la porte (ie sa sortie pourrait être encore à 0 mais elle pourrait aussi être à 1)
De 8.25V...11V => Niveau d'entrée considéré comme un 1
Pour être toujours sûr du niveau de sortie, tu devras donc avoir comme tension d'entrée 0 à 4V (=> sortie à 1) ou 11 à 15V (=> Sortie à 0).
Je te laisse le temps de "digérer"ces infos, je monte une breadboard, je fais le schéma et je te reviens avec les résultats obtenus.
Cela va contraindre à sophistiquer un peu le montage.

Yffig

15
Re...
Je te propose de télécharger sur le site de ON Semiconductors la datasheet intitulée "MC14001B Series" datant de 2005 (plutôt que des plus anciennes souvent illisibles).
A la page 3, tu trouveras les infos suivantes:
-Output Drive Current  (courant de sortie d'une porte) alimentée en 15V  (colonne Vdd Vdc) (une batterie auto bien chargée ou en cours de fin de charge fait quasi 15V): tu as 2 valeurs pour une température de 25°C:
-Source (Ioh) colonne typ.= -8.8 mAdc
-Sink (Iol) colonne typ. = 8.8 mAdc
Cela signifie que la sortie d'une porte CMOS peut délivrer ou absorber un courant de qq mA, disons 5 mA: ça suffit largement pour allumer une led.
A la page 7, figure 10 , tu as la caractéristique de transfert d'une porte CMOS (inverseuse) lorsqu'elle est alimentée en 15V:
Tant que la tension d'entrée est < à 8v environ, la tension de sortie est au niveau haut soit donc environ 15v
Quand la tension d'entrée dépasse un peu plus de 8V, la tension de sortie va très rapidement tomber à 0v.
Tu as donc un circuit qui détecte si une tension est grosso modo soit < 8v plus un poil, soit > à 8V plus "deux poils": tes leds vont pouvoir s'allumer ou s'éteindre comme tu le veux. Par contre tes résistances de 400 ohms sont trop faibles..Pour limiter le courant à environ 5 mA par Led il te faut environ 2.7K...Une led tricolore en boitier translucide  fait çà parfaitement, avec les LED colorées que tu utilises, faut voir...
Je te ferai demain un schéma complet mais il y a juste à ajouter un boitier 14 pattes + support pour souder tranquilou les pinoches et à y ajouter une résistance entre l'entrée de ta "sonde" et la masse pour éviter l'arbre de Noël si tu touches la sonde avec un doigt.
Bonne nuit

Yffig

Pages: [1] 2 3 ... 5