Forum Électro-Bidouilleur

Merci de vous connecter ou de vous inscrire.

Connexion avec identifiant, mot de passe et durée de la session
Recherche avancée  

Nouvelles:

Bienvenue au Forum de discussion Électro-Bidouilleur! Inscrivez-vous pour participer aux discussions!: 
http://forum.bidouilleur.ca/index.php?action=register Les demandes d'inscription sont révisées quotidiennement.

Pages: 1 2 [3] 4 5 ... 10
 21 
 le: janvier 24, 2021, 04:55:41 pm 
Démarré par Fareinheit76 - Dernier message par Fareinheit76
Bonjour
à des fins didactiques, j'essaie d'observer une trame UART avec mon analyseur logique
J'ai essayé avec un arduino où un programme de trame uart a été téléversé mais rien il affiche "sampling" et rien ne se passe
Ensuite
- J'ai envoyé un signal carré Cmos 5V de 9,6Khz de mon générateur de fonction qui correspond à 9600 bauds (conforme sur mon oscilloscope) pas de changement toujours en attente "sampling "
J'ai désinstallé le logiciel et l'ai réinstallé et une fois ouvert connecté l'analyseur logique pour qu'il m'installe le pilote --> pas de problème
mais toujours pareil
Par contre quand j'utilise les pins dédiés de l'analyseur logique en fonction Pwm, j'ai bien la trame sur l'oscillo et il répons bien en changeant la fréquence ou bien le duty cycle
Donc je pense que le port USB est OK
Pour résumer
- ça marche bien dans un sens en sortie du PC vers l'analyseur logique vers oscilloscope (en trame Pwm)
- ça ne marche pas dans l'autre sens en acquisition de trame de quelque entrée que ce soit (j'en ai essayé plusieurs) depuis mon générateur en mode cmos
Avez-vous une suggestion ?
Merci
Cordialement

 22 
 le: janvier 24, 2021, 03:44:14 pm 
Démarré par obewankenobe57 - Dernier message par Curiosus
Bonsoir obewankenobe57,

Puissance de ton moteur (en Watt) et voltage qui est demandé(en volt)

Schéma du branchement de tes panneaux solaires sur les cellules mise en parallèle.

Lien d'achat de ta pompe et panneau solaire


           A+

 23 
 le: janvier 24, 2021, 01:21:45 pm 
Démarré par obewankenobe57 - Dernier message par obewankenobe57
Bonjour,
j'ai fabriqué un panneau solaire à l'aide de deux mini  panneaux 12 v en parallèle pour obtenir en sortie d'environ 3w. J'ai protégé le tout à l'aide d'une diode 1N4001. Je souhaite avec ce panneau alimenter une petite pompe et ça ne fonctionne pas. Les tests de mon panneau montre que je sort bien du 12v max. Je parviens à faire allumer une led sur une plaque d'essais mais pas à faire tourner la pompe.  j'ai un autre panneau qui était livré avec la pompe qui lui fonctionne et je constate que sur ce panneau il y a un petit boitier duquel sort le fil d'alimentation. Y aurait il à l'intérieure un petit montage électronique nécessaire au fonctionnement d'un moteur ?
Merci de votre aide

 24 
 le: janvier 23, 2021, 02:55:29 am 
Démarré par stephcache - Dernier message par Curiosus
Bonjour,

J'ai regardé la vidéo jointe, et je pense que tu peux désactiver le 5 volts on soudant un fils devant le régulateur 5 volts, ça te fera une économie de consommation, par contre tu ne peux pas échappé au régulateur de 3,3 volts, a moins de dessouder une patte  (le 3.3 volts nous sert à rien).

Il y a peut être même pas de soudure à faire en réfléchissant un peu, il faut juste connecter le 5 volts ou c'est marqué +5 volts sur ta carte Arduino.
Avant de faire cela il faudra prendre des mesures, voir à la sortie de ton régulateur de 5 volts si il arrive sur cette sortie +5 volts

Mettre une tension de 5 volts sur la sortie du régulateur de 5 volts ne représente pas de risque.

Par contre si tu le branche sur USB, ou prise DC, faut éviter de le faire,

A+

 25 
 le: janvier 22, 2021, 08:36:51 pm 
Démarré par stephcache - Dernier message par stephcache
Bonsoir

Pour la carte Arduino: https://fr.aliexpress.com/item/32887867329.html?spm=a2g0s.9042311.0.0.27426c37hUKnO5

C'est pas bête de réglè le régulateur DC/DC 5V pour alimenté les deux carte. Je peux pas le désactivé mais je peux m'en passé justement en alimenté directement en 5V.

Regarde cette vidéo si tu le comprend comme moi https://www.youtube.com/watch?v=_JM1JVIn7Zo

 26 
 le: janvier 22, 2021, 07:38:23 pm 
Démarré par stephcache - Dernier message par Curiosus
Bonsoir,

Ok, c'est bien vu pour la désactivation sur le module L298, car le 78M05 consomme beaucoup pour une régulation de 5 volts.

Partir sur un régulateur Dc vers Dc(comme celui que tu as sur la photo c'est mieux) car peu de perte pour ce genre de régulateur.

Par contre, je ne comprends pas pourquoi tu repasses par ta platine Arduino pour faire un 5 volts.

Ça te fait consommé du courant pour rien, il doit bien avoir un moyen pour désactiver le régulateur 5 volts sur ta platine Arduino.

Sur ton module de régulateur Dc vers Dc, tu le règle à 5 volts, et tu alimentes ton : Arduino et ton module L298.

As tu un lien sur ta carte Arduino ?

A+

 27 
 le: janvier 22, 2021, 06:37:47 am 
Démarré par stephcache - Dernier message par stephcache
Je les désactivé car c'est l'arduino qui pilote la carte donc elle qui envoie le 5V.

J'avais pensé me servir du 5V du module L298 mais je pense pas que sa soit possible

 28 
 le: janvier 22, 2021, 04:06:52 am 
Démarré par jeanmidu31 - Dernier message par Électro-Bidouilleur
Bienvenue parmi nous. Amusez-vous bien!

 29 
 le: janvier 22, 2021, 04:03:29 am 
Démarré par cb28 - Dernier message par Électro-Bidouilleur
Bonjour,
Oui, c'est une possibilité. Un décalage sur R6 déplacerait le point d'opération, en effet. Cela permettrait d'utiliser un ampli opérationnel n'étant pas "Rail-to-Rail". Mais le besoin de décalage de tension d'entrée extra-faible demeure. Et comme ce n'est pas difficile de trouver des amplis chopper ayant une réponse Rail-to-Rail, il n'y a pas vraiment d'avantage à ajouter cette source. En plus, on perdrait de la plage d'opération (le 0 à +1V perdu en sortie).

Ce problème d'"aimant" près du zéro Volt est lié à cet OPA333. D'autres amplis chopper n'ont fort probablement pas ce comportement.

 30 
 le: janvier 22, 2021, 12:03:01 am 
Démarré par stephcache - Dernier message par Curiosus
Bonsoir,

C'est bien ce que j'ai pensé, sur ta carte du L298 se trouve un régulateur 5 volts, soit tu l'actives, soit tu le désactive.

Tu as choisi quelle option ?

    A+ 

Pages: 1 2 [3] 4 5 ... 10