Forum Électro-Bidouilleur

Merci de vous connecter ou de vous inscrire.

Connexion avec identifiant, mot de passe et durée de la session
Recherche avancée  

Nouvelles:

Bienvenue au nouveau Forum Électro-Bidouilleur! Inscrivez-vous pour participer aux discussions! L'inscription est automatisée.

Auteur Sujet: Perdu dans la mesure de l'impédance d'une antenne  (Lu 962 fois)

ucdiode86

  • Newbie
  • *
  • Messages: 34
    • Voir le profil
Perdu dans la mesure de l'impédance d'une antenne
« le: avril 04, 2016, 11:20:37 am »

Bonjour à tous,

Suite à l'acquisition d'un VNA (miniVNA tiny pour être plus précis), je me bats depuis plusieurs jours pour comprendre comme adapter mon antenne + le ground du PCB pour avoir une impédance de 50 Ohms.

Ma carte PCB fait en gros 10cm x 10cm qui fait le ground. Un connecteur SMA sort d'un des côtés pour pouvoir connecter l'antenne.

Au début, j'ai connecté le VNA via un petit câble blindé à l'endroit où sera connecté la puce radio, mais les résultat changé constamment.

J'ai ensuite opté pour un connecteur SMA soudé directement à l'endroit où sera la puce radio et les résultats sont maintenant plus constants.

Après cela, j'ai mesuré les caractéristiques du PCB + l'antenne branché dessus.

J'ai trouvé pour Rs 58,1 ohms et Xs -22,1 ohms.

Après avoir utilisé un des nombreux sites qui calcule les valeurs du condensateur et de l'inducteur, j'ai soudé cela (en L ) comme préconisé.

Malheureusement, après soudage, le résultat n'est pas du tout celui espéré. J'obtiens, en gros, 25 ohms pour Rs ( au lieu de 50 attendu ) et 1 ohm pour Xs ( là, c'est pratiquement parfait ).

Je me suis trompé quelque part, mais je n'arrive pas à savoir où.

Les pros de la radio, quelles seraient vos conseils ?

En vous remerciant d'avance de votre aide.
IP archivée

Électro-Bidouilleur

  • Administrator
  • Hero Member
  • *****
  • Messages: 524
  • C'est moi le boss!
    • Voir le profil
    • Site Web Électro-Bidouilleur
Re : Perdu dans la mesure de l'impédance d'une antenne
« Réponse #1 le: avril 04, 2016, 11:42:54 am »

Bonjour ucdiode86,

Sujet intéressant.
  • À quelle fréquence faites-vous vos mesures?
  • Je suspecte que votre arrangement de départ (les interfaces) n'est pas bon, et que votre Rs 58,1 ohms et Xs -22,1 ohms ne représente pas la réalité.
  • Comment avez-vous fait la calibration du VNA juste avant de le connecter à votre montage?

Pourquoi ne pas fournir des images de bonne qualité de votre montage. On pourra savoir de quoi il s'agit.

IP archivée

eledtronik

  • Administrator
  • Sr. Member
  • *****
  • Messages: 291
  • apprendre c'est bien, le partager c'est mieux
    • Voir le profil
Re : Perdu dans la mesure de l'impédance d'une antenne
« Réponse #2 le: avril 04, 2016, 12:55:00 pm »

bonjour

j'ai également  un VNA outil très pratique, ma question est comment branchez-vous votre antenne , utilisez -vous un pont reflectometrique ?

car en direct sa ne fonctionnera pas, un petit schéma ou un photo serait le bien venu pour pouvoir vous aidez

cdlt

pascal F4HGQ

IP archivée

ucdiode86

  • Newbie
  • *
  • Messages: 34
    • Voir le profil
Re : Re : Perdu dans la mesure de l'impédance d'une antenne
« Réponse #3 le: avril 04, 2016, 01:00:34 pm »

Bonjour Electro-Bidouilleur,
Citation de: Électro-Bidouilleur
  • À quelle fréquence faites-vous vos mesures?
863 à 865Mhz. Pour les calculs, j'ai pris la mesure du 864Mhz.

La sortie de la puce transmetteur est donné pour une impédance de 50 ohms. D'où ma recherche de la même valeur avec l'antenne + PCB.

Citation de: Électro-Bidouilleur
  • Je suspecte que votre arrangement de départ (les interfaces) n'est pas bon, et que votre Rs 58,1 ohms et Xs -22,1 ohms ne représente pas la réalité.

Ah, possible. Voici 2 photos du montage actuellement utilisé pour la mesure.
Citation de: Électro-Bidouilleur
  • Comment avez-vous fait la calibration du VNA juste avant de le connecter à votre montage?
Pourquoi ne pas fournir des images de bonne qualité de votre montage. On pourra savoir de quoi il s'agit.

J'ai utilisé les pièces de calibration jointes (court-circuit, ouvert et 50 ohms). Je les ai utilisés directement en sortie du VNA.

Par contre, n'ayant pour l'instant pas d'adaptateur, je n'ai pas pu mettre les éléments de calibration à la sortie de l'adapteur male-male SMA (que l'on voie au dos du PCB).

Voici les photos.

Merci pour l'aide.

Cordialement.
« Modifié: avril 04, 2016, 01:07:35 pm par ucdiode86 »
IP archivée

ucdiode86

  • Newbie
  • *
  • Messages: 34
    • Voir le profil
Re : Re : Perdu dans la mesure de l'impédance d'une antenne
« Réponse #4 le: avril 04, 2016, 01:05:16 pm »

bonjour

j'ai également  un VNA outil très pratique, ma question est comment branchez-vous votre antenne , utilisez -vous un pont reflectometrique ?

car en direct sa ne fonctionnera pas, un petit schéma ou un photo serait le bien venu pour pouvoir vous aidez

cdlt

pascal F4HGQ

Non, pas de pont reflectometrique. Juste le VNA le plus proche de là où sera emis les ondes de la puce radio.

Un exemple de pont ?

Merci pour l'aide.

Cordialement.
IP archivée

Électro-Bidouilleur

  • Administrator
  • Hero Member
  • *****
  • Messages: 524
  • C'est moi le boss!
    • Voir le profil
    • Site Web Électro-Bidouilleur
Re : Perdu dans la mesure de l'impédance d'une antenne
« Réponse #5 le: avril 04, 2016, 04:10:42 pm »

Votre lecture d'impédance se fait exactement au point de connexion du VNA. C'est là que vous avez fait la calibration. Avez vous installé votre compensation à cet endroit? Et même si vous faites cela, cela ne fera qu'ajuster l'impédance à ce point. Ça ne règlera pas des problèmes potentiels ailleurs sur la ligne ou à l'antenne...

Moi j'aurais tendance à diviser le problème en deux (ou plusieurs) segments. Avez-vous d'abord caractérisé l'antenne? À quoi bon compenser à la source si l'antenne ne se couple pas bien à la ligne de transmission... Vous voulez avoir une impédance uniforme d'un bout à l'autre. Si votre antenne a une impédance loin des 50 ohms, vous aurez beaucoup de réflexions.

Mesurez votre ligne avec une terminaison de 50 ohms connue au lieu de l'antenne. Vous pourrez dériver l'impédance de la ligne sans les effets de l'antenne.

Cela dit, la ligne de transmission est tres courte comparé à la longueur d'onde. On est donc loin du comportement typique d'une ligne de transmision. Ainsi, il est possible que les mesures soient difficiles à faire compte tenu de cela et du fait que les connecteurs et adaptateurs deviennent significatifs en comparaison à la courte ligne.

Je suis certain qu'il y en aura d'autres pour ajouter à mon commentaire....
IP archivée

eledtronik

  • Administrator
  • Sr. Member
  • *****
  • Messages: 291
  • apprendre c'est bien, le partager c'est mieux
    • Voir le profil
Re : Perdu dans la mesure de l'impédance d'une antenne
« Réponse #6 le: avril 04, 2016, 05:49:58 pm »

tout à fait d’accord , il faut tout d’abord mettre un bouchon 50ohm surtout que ces antennes boudin  j'en est testée déjà pleins avec le vna , en générale elle sont toutes à coté de la plaque,après vu la puissance ce n'est peut être pas significatif
faut pas chercher la petite bête a ces fréquences  c'est mon avis .


IP archivée

ucdiode86

  • Newbie
  • *
  • Messages: 34
    • Voir le profil
Re : Perdu dans la mesure de l'impédance d'une antenne
« Réponse #7 le: avril 06, 2016, 10:16:11 pm »

Bonjour à tous,

Suite à la lecture de vos conseils, j'ai tout repris à 0.

Dans un premier temps, j'ai fait une calibration avec les bouchons vendus avec (50 ohms, court-circuit, et ouvert) directement en sortie du VNA.
J'y ai branché ensuite l'antenne seule.

Voici le résultat :

|Z| : 82,3 ohms @ 863 Mhz          Rs : 82,2 ohms @ 863 Mhz         Xs : -4,3 ohms @ 863 Mhz                             
|Z| : 80,2 ohms @ 865 Mhz          Rs : 79,7 ohms @ 865 Mhz         Xs : -9,0 ohms @ 865 Mhz

Voici la courbe dans le document Antenne_1_4_Onde_Droit.

Antenne seule - Courbe Rs et Xs
Antenne seule - Courbe SWR et |Z|

Dans un second temps, j'ai refait la calibration en plaçant une résistance de 49.9 ohms (je n'avais que cela sous la main) aux extrémité du SMA que j'ai placé là où le transmetteur radio va commencer à émettre. J'ai ensuite retirer la résistance, puis souder pour fait un court-circuit. Pour la mesure en mode ouvert, il n'y avait rien.

Aucun bouchon n'a pu être utilisé pour la calibration à cet endroit. Les 3 modes (ouvert, court-circuit et 50 ohms) ont été réalisé sur la patte du SMA en entrée, j'ai dessoudé préalablement la patte centrale du SMA et la piste PCB de transmission.

Après cette 2ème calibration, voici le résultat du PCB + Antenne :

|Z| : 33,4 ohms @ 863 Mhz          Rs : 31,4 ohms @ 863 Mhz         Xs : -11,3 ohms @ 863 Mhz                             
|Z| : 32,6 ohms @ 865 Mhz          Rs :31,2 ohms @ 865 Mhz          Xs : -9,3 ohms @ 865 Mhz

La 1ère conclusion, c'est que l'impédance chute fortement avec le PCB. Les résultats sont différents du premier essai d'y il y a quelques jours.

Je vais recalculer les valeurs du condensateur + inductance à ajouter et voir le résultat ....

PCB + Antenne - Courbe Rs et Xs
PCB + Antenne - Courbe SWR et |Z|

A+
Seb.
« Modifié: avril 07, 2016, 09:03:29 am par ucdiode86 »
IP archivée

ucdiode86

  • Newbie
  • *
  • Messages: 34
    • Voir le profil
Re : Perdu dans la mesure de l'impédance d'une antenne
« Réponse #8 le: avril 07, 2016, 09:13:30 am »

Bonjour à tous,

Alors après avoir calibré (bien j'espère cette fois-ci) le VNA et mesuré les caractéristiques du PCB + Antenne, j'ai calculé les valeurs du condensateur et de l'inductance pour avoir une impédance de 50 ohms. Cela nous donne :

Cs = 13.25 pF     Ls = 11.91 nH
Type de montage : en L.

Bon, j'ai bien 12nH en inductance, mais pas le condensateur. Le plus proche que j'ai, c'est 10pF.

Après avoir soudé ces 2 éléments, voici les résultats :

|Z| : 48,8 ohms @ 863 Mhz          Rs : 47,5 ohms @ 863 Mhz         Xs : -10,9 ohms @ 863 Mhz                             
|Z| : 46,1 ohms @ 865 Mhz          Rs : 45 ohms @ 865 Mhz         Xs : -9,7 ohms @ 865 Mhz

PCB + Antenne avec adaptation - Courbe Rs et Xs
PCB + Antenne avec adaptation - Courbe SWR et |Z|

Je suis hyper content du résultat. N'ayant pas 13pF, mais 10 (soit 3pF de moins), j'ai tout de même le résultat proche de celui recherché ! :D

Par contre, j'ai découvert que les antennes que j'ai à ma disposition, non pas du tout les mêmes caractéristiques les unes par rapport aux autres ! Pourtant, même taille, mais pas le même fabricant ???

Vous avez déjà remarqué cela ?

En attendant vos différentes expériences, je vous remercie pour l'aide que vous m'avez apporté.  8)

Allez c'est partie pour le test de portée radio :)

A+
Seb.
« Modifié: avril 07, 2016, 09:17:21 am par ucdiode86 »
IP archivée