Forum Électro-Bidouilleur

Merci de vous connecter ou de vous inscrire.

Connexion avec identifiant, mot de passe et durée de la session
Recherche avancée  

Nouvelles:

Bienvenue au nouveau Forum Électro-Bidouilleur! Inscrivez-vous pour participer aux discussions! L'inscription est automatisée.

Auteur Sujet: fpga problème conception avec Quartus Prime  (Lu 158 fois)

kamill

  • Newbie
  • *
  • Messages: 17
    • Voir le profil
fpga problème conception avec Quartus Prime
« le: mars 19, 2019, 04:03:21 pm »

Bonjour à tous,

Je suis très intéressée par les vidéo sur les fpga de la chaîne electo-bidouilleur et je suis en  train de faire quelques essais.
Je cherche à générer deux signaux en quadrature de phase.

J'ai donc essayé le schéma suivant avec Quartus Prime et la carte de test préconisée par Bertrand.


J'injecte un signal carré sur l'entrée et lorsque je teste, la sortie S1 reste toujours à l'état haut. Je ne comprend absolument pas pourquoi.

Alors qu'avec le schéma suivant ça fonctionne correctement et j'ai bien deux signaux en quadrature de phase


Comme je ne voudrais pas mourir idiot, est ce que quelqu'un à une explication sur le fait que le premier schéma ne fonctionne pas et surtout pourquoi la sortie S1 reste toujours à l'état haut.

Merci.
IP archivée

papyblue

  • Full Member
  • ***
  • Messages: 107
    • Voir le profil
Re : fpga problème conception avec Quartus Prime
« Réponse #1 le: mars 19, 2019, 05:25:49 pm »

Bonjour,
Quand une sortie est figée (à 0 ou Vcc) Quartus le dit dans les warnings affichés, avez-vous lu ces informations ?
Ne voyant pas ou est l'erreur j'ai simulé votre schéma : conclusion ça marche.
A ceci près que faire de la logique asynchrone en combinant l'horloge est une mauvaise idée. Pour avoir des signaux corrects, je vous encourage à ne faire que de la logique synchrone , les signaux en sortie doivent être des sorties de bascules pilotées par la même horloge.
L'image jointe est la simulation de votre montage et met en évidence le problème.
Ci-joint un schéma qui devrait répondre à votre besoin.
« Modifié: mars 19, 2019, 07:08:41 pm par papyblue »
IP archivée

kamill

  • Newbie
  • *
  • Messages: 17
    • Voir le profil
Re : fpga problème conception avec Quartus Prime
« Réponse #2 le: mars 19, 2019, 07:09:42 pm »

Merci pour ta réponse.
J'ai quelques warning, mais ce sont les les mêmes dans le premier et deuxième cas
Voila les signaux de sortie (S1: jaune, S2: rose)
1er schéma -> problème

2ème schéma -> ok


Franchement je ne comprend pas les deux schémas sont quasiment identiques sauf que l'entrée de la porte xor est connectée sur Q dans le premier et sur Q/ dans le second.

Je suis d'accord avec toi le schéma n'est pas très bon car il génère des glitchs. C'est juste un "exercice de style"

Le schéma que j'ai retenu et que j'ai implémenté avec des circuits 74HCXXX discrets est le suivant


Mais ton schéma est meilleur car il ne demande qu'un boitier  :)
« Modifié: mars 19, 2019, 08:08:27 pm par kamill »
IP archivée

papyblue

  • Full Member
  • ***
  • Messages: 107
    • Voir le profil
Re : fpga problème conception avec Quartus Prime
« Réponse #3 le: mars 19, 2019, 10:09:42 pm »

J'ai chargé dans ma carte Cyclone IV avec le premier schéma et branché mon scope, conclusion : ça marche (les deux signaux sont présents)
IP archivée

kamill

  • Newbie
  • *
  • Messages: 17
    • Voir le profil
Re : fpga problème conception avec Quartus Prime
« Réponse #4 le: mars 19, 2019, 10:19:02 pm »

Merci pour ton essai.
C'est à ne rien y comprendre, chez moi ça ne veut désespérément pas fonctionner.
Je ne pense pas que ça vienne de la carte car si je met une porte not entre Q/ et l'entrée du xor ça fonctionne (on est ramené au deuxième schéma)
J'ai essayé avec d'autres pins, toujours le même problème.
IP archivée