Forum Électro-Bidouilleur

Merci de vous connecter ou de vous inscrire.

Connexion avec identifiant, mot de passe et durée de la session
Recherche avancée  

Nouvelles:

Bienvenue au nouveau Forum Électro-Bidouilleur! Inscrivez-vous pour participer aux discussions! L'inscription est automatisée.

Auteur Sujet: compréhension schéma alimentation de laboratoire et amélioration  (Lu 1456 fois)

Yffig

  • Jr. Member
  • **
  • Messages: 86
    • Voir le profil
Re : compréhension schéma alimentation de laboratoire et amélioration
« Réponse #45 le: août 10, 2019, 01:05:44 pm »

Tant mieux que tu aies trouvé ce qu'il te fallait,... j'aime aussi fouiller dans mes "poubelles" (et aussi celles des déchetteries...y'a du gros transfo, du radiateur maousse et plein de trucs qui vont très certainement être enfouis pour bien pourrir les sols...).

Ce serait très chouette que tu puisses poster quelques résultats de tests que tu réaliseras sur ton alim: le design de base de cette alim chinoise est vraiment intéressant car simple bien qu'il ait quelques défauts de conception, finalement assez identifiables.
Le premier kit que j'avais acheté sur BangGood (environ 10 USD), monté avec le 2SD1047 sur radiateur MAOUSSE COSTAUD, testé avec des 12v/20W halogènes en // m'avait convaincu.... j'avais alors acheté un 2° kit sur AliExpress plus les radiateurs et ventilos qui vont avec ( grosso modo la même chose que la charge active 60W que Bertrand a testé et que j'avais aussi). C'est là que les ennuis ont commencé... 3 x SD1047 cramés, sorties mises à la tension non régulée....Aie aie aie... !
J'ai alors réalisé que la "régulation de courant max" ne réagissait pas assez vite et qu'il manquait la classique et très simple protection OverCurrent que j'ai proposée (et pour laquelle je n'ai aucune paternité, c'est un grand classique des années 70's).
Si tu l'implémentes dès le départ avec un bon gros radiateur tu devrais pouvoir la stresser... maavec un 2SD1047 comme ballast essaie cependant de rester à 50W max de dissipation pour du long terme

IP archivée

ksyrium

  • Newbie
  • *
  • Messages: 37
    • Voir le profil
Re : compréhension schéma alimentation de laboratoire et amélioration
« Réponse #46 le: août 10, 2019, 07:47:51 pm »

Bon ,voici quelques tests de l'alimentation en PJ.
Il faut garder en mémoire que l'alimentation est branchée sur un transformateur qui est loin de fournir les 24Vca sous 3A...
En gros, 20Vcc max et 4A en Court-circuit (16V, 2.6A en fonctionnement nominal sur l'alimentation d'origine).

1er test : sortie en court-circuit franc sans limitation.
2e test : sortie en court-circuit franc avec limitation à 0.2A.
3e test : sortie réglée à 12V et limitation réglée sur 0.1A. test sur une boite à décades (11 positions par rotacteur ce qui explique les petits sauts sur la tension).
En plus, une photo de l'alimentation en test avec son afficheur Chinois...

L'on remarquera que sur court-circuit direct, l'intensité donne un pic élevé (15A) mais très bref, la limitation réagit en gros en 0.2ms pour redonner ensuite un "petit" pic d'intensité.
Pas sûr donc, qu'avec le transformateur associé le transistor puisse claquer. Sur la datassheet, le 2DS1047 est donné pour un pic de 20A < 5ms, on en est loin.
IP archivée

Yffig

  • Jr. Member
  • **
  • Messages: 86
    • Voir le profil
Re : compréhension schéma alimentation de laboratoire et amélioration
« Réponse #47 le: août 11, 2019, 08:28:31 am »

Bonjour Ksyrium,
Bravo pour tes pièces jointes, je vois que tu disposes des outils nécessaires.
Néanmoins, il faudrait que tu précises quelques points pour clarifier:
-le montage que tu testes, est ce bien: la carte originale avec 741s et sans OverCurrent Protection ? avec 10µF en sortie C7 et la diode D11 en inverse ?
-Premier test: tu fais un "court circuit" pendant 500µs, le courant (courbe rouge) monte à 15A  mais ta tension de sortie (courbe bleue) est à environ 5V ??? , puis le courant se stabilise à 4A, puis apparemment tu ouvres le court circuit :une pointe de courant <0 de -4A selon ton échelle et le court circuit se refait...; à 900 µs il est parfait, le courant est stabilisé à 4A mais tu as apparemment une tension en sortie > à 1V au moins (à moins que ce ne soit le 0v de ton canal bleu qui ne soit pas bien aligné ? )
Difficile de bien comprendre sans que tu ne nous fasse un croquis du test: je vois 2 shunts en série (de quelles valeurs ? ) pour les 2 ampèremètres , peut être un troisième pour mesurer le courant sur ton scope à moins que tu ne le prenne sur la 0.47 du Current Sense ou un des 2 shunts...Ca ne fait pas un vrai court jus. De plus en pratique le court jus va durer plusieurs secondes voire des minutes.
Et pourquoi ça va juqu'à 4 A (et pas environ 3A comme prévu selon les specs) ? Et combien de temps tu restes en CC ? Et ton transfo 2.6A , il apprécie les 4A ? Ton 2SD1047 il voit 20V*4A = 80W...il tiendra pas bien longtemps même avec ton radiateur de bonne taille. tu as raison pour le paramètre Icm: la Safe Operating Area (fig2 de la datasheet) te donne même 20A et 30V pendant 3 ms (mais très certainement à température du boitier maintenue à 25°).
Pour le second test, on a du mal à voir le 0.2A sur ton scope mais tu as la même séquence: CC, ouvert puis CC final au niveau du contact. avec quasi  le même timing, curieux si tu fais ce CC à la main, non ?
Pour le 3ème test, tu vérifies donc que quelque soit la charge le courant se maintient bien  à la valeur demandée 0.1A:  RAS

Pour mémoire, je te renvoie à mon message du 14 mai sur ce fil où je critique la méthodologie des test faits par un russe. Les mêmes tests avec des halogènes faits par moi m'ont explosé 3 x 2SD1047 de 2 fournisseurs différents (puisque celui d'AliExpress a accepté de m'envoyer un 1047 de rechange).
Maintenant, beaucoup de bidouilleurs sont très satisfaits de cette alim telle qu'elle est. Tant mieux pour eux !
Pour être plus précis dans l'objet de mes critiques sur cette alim (que, je le rappelle, j'ai un peu modifiée et qui me satisfait alors pleinement), je ne fais pas ces critiques pour le plaisir d'être négatif mais, compte tenu des déboires que j'ai connu (et je ne suis pas le seul), je voudrais seulement:
- éviter que des bidouilleurs souvent peu fortunés se retrouvent avec un 2SD1047 en court jus et alors avec 30V direct sur leur montage...,
- et aussi pour le plaisir d'analyser et de comprendre ce qui s'est passé: il y toujours à apprendre !

Je te remercie si tu trouves le temps de répondre à mes interrogations.

Yffig




IP archivée

ksyrium

  • Newbie
  • *
  • Messages: 37
    • Voir le profil
Re : compréhension schéma alimentation de laboratoire et amélioration
« Réponse #48 le: août 11, 2019, 12:48:01 pm »

Bonjour Yffig,

Pour le test, la résistance shunt est une 0.47ohms/5W standard mise entre les bornes + et - de l'alimentation avec en plus un ampèremètre en série pour vérifier les mesures. Attention, avec les fils (fins type breadboard), l'ampèremètre, les résistances de contact... les mesures ne sont pas certifiées "laboratoire"  :D.
L'enregistreur est un Picoscope 10Mhz, type 2204A avec le logiciel Picolog (franchement une merveille ce truc-là).

La photo correspond au test de l'afficheur Chinois et n'a rien à voir avec les enregistrements  ;)

La carte testée est originale à 100% avec des TL081 qui fonctionnent, sans aucune modification.

Pour les tests en CC, le court-circuit est franc (2 fiches bananes 4mm en contact) et maintenu plusieurs secondes (2 ou 3).

Le 2e pic de courant est présent sur tous les enregistrements effectués. Peut-être un phénomène dû à la vitesse de commutation de l'électronique ?
Ce qui m' intéressait était de visualiser le temps de réponse de la limitation et le pic maximum d'intensité sur "cc franc"...
Pour les 2V en sortie, je pense que c'est correct. Le shunt étant de 0.47ohms avec 4A, cela fait bien 2V.
Après, l'analyse des phénomènes transitoires est souvent très difficile et parfois, les explications deviennent extravagantes...
Je pense qu'il faut surtout en retenir un temps de mise en place d'une limitation de courant stable à 900µs et un courant de 12Amax avec le transformateur testé. Ce dernier point changera certainement avec un autre transformateur...

Effectivement, ce n'est pas un CC franc mais ça s'en approche, j'avais essayé avec un shunt à 0.1 ohm, mais la tension mesurée par le scope n'était pas juste (trop basse) et perdue dans le bruit.

A mon avis, les 30V/3A de cette alimentation sont plus commerciaux qu'autre chose et il vaut mieux rester modeste en choisissant un transformateur permettant une limitation physique des caractéristiques maximales obtenues en sortie...
On n'utilise pas un composant sur ces valeurs maxi de datasheet et pour ce kit, c'est la même chose...
Pour 30V/3A, il vaut mieux faire comme Cécile et tout repenser (mais c'est plus long, fastidieux et plus cher).
IP archivée

Yffig

  • Jr. Member
  • **
  • Messages: 86
    • Voir le profil
Re : compréhension schéma alimentation de laboratoire et amélioration
« Réponse #49 le: août 11, 2019, 10:11:23 pm »

Bonsoir Ksyrium (et Bonjour Cécile qui a créé ce fil et le suit assidument),

Merci beaucoup pour ces précisions.

Je vais ici détailler comment ça marche chez moi sur cette alim chinoise après modifications par mes soins à cause de mes déboires initiaux (peut être occasionnés par le passage d'un radiateur maousse costaud initialement utilisé pour tests rapides à la solution plus compacte d'un plus petit radiateur avec ventilation forcée (utilisant le régulateur LM7824 de la carte) qui est la solution "préconisée" par beaucoup de vendeurs sur AliExpress) (pj: PS 30V-3A Heatsinks view .JPG à l'intention de Cécile tout particulièrement puisque c'est son intention) .
Le schéma de mon alim a été joint à mon tout premier message sur ce fil et je l'utiliserai en référence dans mon propos.

Tout d'abord: alim réglée à Vreg=10V à vide, potard I_lim mis à 0 A, (pj: PS at 10V NO load.jpg), je shorte la sortie de l'alim et je règle I_lim à 1.00 A (pj: PS at 10V SHORTED at lim 1A.jpg). La tension de sortie tombe à 8.6mV => on peut en déduire que mon court circuit fait 8.6 milliOhms très exactement...
(Une petite note sur les afficheurs chinois 5 digits utilisés et qui m'ont vraiment bluffé: vendus pas chers directement par petit lot (genre x4) sur AliExpress, je les ai comparé à mon Keysight 6.5 digits... et bin, ça craint pas ! Bien sûr y'a un poil de décalage mais à 0.1% ils sont quasi parfaits et stables à température domestique et permettent donc de vérifier la stabilité de la tension et du courant de l'alim. J'ai une petite idée de la façon dont ils fonctionnent mais c'est un autre sujet..).

Je passe au test de réponse transitoire à un court jus: le coupable mesure donc environ 9 millOhms et je mesure le courant délivré par l'alim directement sur la résistance de Current Sense (RS2 de mon schéma). C'est une résistance constituée de 10 x SMD2512 (1W et 0.05 Ohms chacune) soit 0.5 Ohms (en fait on verra que c'est 0.528 Ohms soit 5% d'erreur).

L'enregistrement par un Picoscope DMSO 2206 (200 MHz...) et aussi visualisée sur un Rigol DS1054Z (50 MHz)  ne laisse aucun doute (pj: PS at 10v-lim 1A.jpg):
- la limitation OverCurrent agit dès le départ et limite très proprement le courant à 3A comme prévu(*)
- le courant, comme pour les relevés de Ksyrium, passe alors à 0,00A au bout de 123 µs ..(je pense que c'est dû au basculement de la sortie du comparateur à -5V)
- et finalement le courant se stabilise à sa valeur de consigne de 1.00A (174 µs après le court jus) soit les 0.528 V mesurés.

Par rapport au comportement relevé par Ksyrium sur l'alim originale, je ferai deux commentaires:
1/ à "mon" avantage, c'est très propre, pas de surintensités, des fronts de montée "smooth"
2/ par contre, la vitesse de réaction est beaucoup plus lente même si elle est quand même rapide: 123µs versus < 1µs. Je ne suis pas certain de la raison mais il y a une différence très importante qui pourrait en être la cause: l'alim originale telle qu'utilisée par Ksyrium utilise un électrolytique de 10µF en // sur la sortie, ma version utilise un 1000 µF...donc un rapport 100 qui se retrouverait dans les mesures ? why not ? (J'ai expliqué pourquoi je faisais cela et je pourrais développer ce sujet mais c'est un sujet loin d'être évident...comportement en présence d'une charge capacitive et stabilité en fréquence,vaste sujet et pas mal de boulot....).

(*): sur mon schéma on trouve Rs1 comme Current Sense de l'OverCurrent: elle est en fait constituée de 3x SMD2512 1W 0.1 Ohms en série pour une limitation à 2A et, par le jeu d'un jumper, de la mise en // de 0.6 ohms sur la 0.3 qui donne une limitation à 3A qui est ce qui a été mis en oeuvre lors de mes tests.

Pour conclure ce (long) exposé, je voudrais simplement rappeler qu'une ALIM de LABO doit pouvoir subir TOUTES les avanies qu'un bidouilleur va lui faire subir sans lui cramer tout son montage. C'est ce que j'ai essayé de documenter sur ce fil et je souhaite sincèrement que la communauté en bénéficie.

Yffig

IP archivée

ksyrium

  • Newbie
  • *
  • Messages: 37
    • Voir le profil
Re : compréhension schéma alimentation de laboratoire et amélioration
« Réponse #50 le: août 12, 2019, 04:24:05 am »

Bonjour Yffig,

Merci pour toute cette longue explication et présentation (beau montage).
Sur ton schéma, j'ai du mal à comprendre le condensateur de 1000uF en sortie.
Si tu coupe ton alim., tu as donc la décharge du condensateur dans le montage. Il ne me semble pas avoir déjà vu cela...
S'il te reste de la place, tu pourrais rajouter un relais pour couper directement chaque sortie depuis la face avant. En plus c'est bien pratique et présent sur les bonnes alimentations pro. actuelles.
IP archivée

Yffig

  • Jr. Member
  • **
  • Messages: 86
    • Voir le profil
Re : compréhension schéma alimentation de laboratoire et amélioration
« Réponse #51 le: août 12, 2019, 08:35:23 am »

Bonjour Ksyrium,
Concernant ce condo  C8 passé de 10 à 1000µF, j'ai fourni sur ce fil (en haut de page 2, message daté du 11 mai) un premier élément  de réponse, et je vais détailler un peu plus:

Tu te trompes en pensant que tu ne penses pas" avoir déjà vu cela". Tu l'as utilisé sans le voir... En effet quand tu branches une ou plusieurs cartes sur ton alim, tu as quasiment toujours sur l'entrée alim de tes cartes des électrolytiques ou tantales de 47 à 470µF en général donc tu peux avoir facilement tes 1000µF branchés en sortie de ton alim. Si tu n'as pas ces condos sur tes cartes, soit c'est parce que tu as oublié de les mettre  ;) soit plutôt que le fabricant a voulu faire des économies de bout de chandelle.

Donc comme je l'écrivait le 11 mai, je place d'office ce 1000µ/63V en sortie d'alim et j'y mets un chimique de qualité (Nichicon, etc.) avec un très bon ESR, doublé d'un céramique 0.1µ/50V. Ensuite quand je fais les tests de stress de mon alim  je pousse le "sadisme" à la charger avec 10 000µ (quand c'est une alim un tant soit peu sérieuse, pas un 78L05 en boitier TO92...!).
Cela m'assure que quand je brancherais mon alim sur un ensemble de cartes, ça tiendra (mais il y a un très GROS détail que je laisse de côté pour l'instant).
En ce qui concerne les "inconvénients"
1- A la mise sous tension de l'alim ce condo, le courant est au max de 3A (moins si I_lim n'est pas au max). J'aurai alors un dV/dt de ma tension de sortie = I/C soit 3A/1000*F=3000V/s., donc 10 ms pour monter à 30V. Ca le fait donc même si j'ai I_lim beaucoup plus bas, par ex si j'ai I_lim minimum #20mA par un canal, alors un dV/dt de 20V/s ce qui peut même être considéré comme un avantage du type"soft start" !
2- Quand mon alim est up et alimente une carte, le 1000µ va pouvoir se décharger dans la carte si je baisse la tension,
3- Si elle n'est pas branchée donc à vide, j'avais constaté que le "courant de repos" tel qu'indiqué par l'ampèremètre était de #30 mA  soit un dV/dt à vide de 30V/s. Avec un potard 10 tours je te mets au défi de dépasser manuellement cette vitesse en voulant baisser très rapidement la tension de consigne. Ces 30 mA de courant de repos m'ont d'ailleurs obligé à injecter le même courant en inverse uniquement sur le shunt de l'ampèremètre (cf le "I_Offset Compensation" en bas de mon schéma et les deux petits transfo bleus à droite que l'on voit sur le châssis) afin de ne mesurer que le courant délivré à la charge
4- Quand j'éteins l'alim et qu'elle n'est pas chargée, la diode de protection inverse du ballast décharge le 1000µ dans la partie non régulée via la résistance "bleeder" de 2.2K qui vient de l'alim chinoise.
(Si tu vois qq chose que j'aurais oublié de prendre en compte, je suis dispo pour en discuter mais je crois avoir fait le tour).
D'ailleurs j'ai vu pas mal d'alims "pro" qui ont un bon condo en sortie...

Et enfin, le très GROS "détail" qui mérite un plus long développement et j'y travaille depuis un bon moment mais LT-Spice me fait des misères: c'est l'effet de ce condo sur l'asservissement de tension:
Tous les "vieux" bidouilleurs (et plus jeunes aussi) se sont heurtés à la loi de Murphy: "Tu veux faire un oscillateur, y marche pas ! Tu veux faire une alim stabilisée ou un ampli, ça oscille !!!".
En effet alim et amplis n'aiment vraiment pas les charges capacitives. Mon approche pour les alims est alors:
-comme j'aurais très certainement à alimenter des cartes avec des gros condos (cf plus haut) je ne peux pas faire comme si cela n'existait pas
- je sais que la présence de ces condos en sortie fait tourner la phase en boucle OUVERTE et entraîne des oscillations dans la boucle fermée même SI ON NE LES VOIT PAS EN SORTIE CAR "ABSORBéES" PAR LE(S) CONDO(S) (d'où la note sur mon schéma "Test point scope sur pin condo" sur la sortie du LT1057 où je place une sonde x10 (pas une 1x !!) pour regarder la stabilité de la boucle fermée.
Donc en boucle ouverte, j'ai plein de pôles: ceux de l'ampli op, ceux des transistors drivers et ballast plus celui crée par mon gros condo => Il me faut donc ajouter un POLE suffisamment bas en fréquence pour que en boucle FERMéE, l'ensemble soit stable même si je branche 10 000 µF en sortie. C'est le rôle de C13 qui a été "tuné" et soudé directement sur les pins du DIP8 en fin de tests. Selon Horowitz (The Art of Electronics) ce condo peut même aller jusqu'à 1nF.
Et voilà , c'est nickel !
NB: la résistance Rs1 d'OverCurrent joue aussi un rôle important en augmentant un poil l'impédance de sortie en boucle ouverte (et certifié par simulations LT-Spice : disparition des oscillations avec qq 0.1 Ohms !).
Ce "détail" mériterait un bien plus grand développement (j'y travaille mais sans savoir si j'en viendrai à bout: faire des simulations en boucle OUVERTE est loin d'être impossible mais Spice ne fait des misères...)
On peut critiquer mon approche avec un argumentaire du genre "OUI, bon mais tu as alors une alim qui réagit "trop lentement" aux appels de courant". C'est un argument "bidon": je demande à une alim une excellente stabilité de "moyen terme" et je laisse aux différents condos de découplage (et donc à mon fameux 1000µF) de fournir les pointes de courant demandées par les circuits alimentés: c'est à ça qu'ils servent !

Voilà les explications que je livre à ta perspicacité, un peu longues certes, mais ce sont des aspects qui méritent effectivement que l'on s'y attarde: ça fait la différence entre une daube et une alim que tu peux utiliser en toute confiance.
Dans ce cadre, j'attire ton attention sur un autre "BUG MORTEL" de l'alim originale: j'avais mis au départ des 10 tours chinois (BOURNS bien imités... de l'extérieur )pour le réglage de la tension... Pi, un jour, le curseur de ce potard a "sauté" la piste (bobinée dans ce cas) et je me suis retrouvé avec la tension de sortie au MAXIMUM !Heureusement que c'était pendant que je faisais des tests avec des halogènes 12V. Il suffit de mettre une résistance pour éviter la catastrophe: ce sont *R19 et *R20 de mon schéma sur les entrées des amp op qui ramènent les entrées au 0v au cas où .Et puis j'ai mis des 10 tours Vishay Spectrol achetés chez Reichelt.

Sinon, non, je ne mettrais pas de relais ni de bouton poussoir de short. J'ai encore assez de temps à perdre pour brancher et débrancher des fils.

Bonne journée

Yffig





 
IP archivée

ksyrium

  • Newbie
  • *
  • Messages: 37
    • Voir le profil
Re : compréhension schéma alimentation de laboratoire et amélioration
« Réponse #52 le: août 12, 2019, 04:31:27 pm »

Merci pour cette longue réponse.
Je ne voyais pas la fonction du condensateur de sortie comme cela, ça dépasse un peu mes compétences...

Pour les potentiomètres, je ne pensais pas mettre un multi-tours, mais plutôt garder le 10k seul et peut-être rajouter en série un 1k en réglage fin. Seulement, la place risque de manquer en face avant... En plus il faut prévoir le changement de ceux livrés d'origine qui font un peu cheap...

Je rajouterais certainement aussi un bouton pour faire court-circuit en face avant, afin de régler facilement la limitation de I. Voir un autre pour couper chaque sortie  :)
Mais bon, ce n'est pas une priorité.

Il faut aussi que je test "ta" modification d'overcurrent, avec la résistance achetée, je devrais être à 3A.
Si tout va bien, le projet devrait pouvoir arriver à bon terme, dans quelques temps...

Bravo pour tes CI, le plan de masse est super.
Je n'avais jamais vu les modules chinois à 5 digits que tu as monté en face avant.
« Modifié: août 12, 2019, 04:34:27 pm par ksyrium »
IP archivée

Yffig

  • Jr. Member
  • **
  • Messages: 86
    • Voir le profil
Re : compréhension schéma alimentation de laboratoire et amélioration
« Réponse #53 le: août 12, 2019, 08:27:30 pm »

Bonsoir Ksyrium,

En ce qui concerne la compensation en fréquence de la partie régulation en tension d'une alim ce n'est pas très compliqué: il faut couper la bande passante de l'ampli op pour qu'il n'oscille pas. Je te recommande vivement de placer une sonde X10 ( et compensée bien sûr) sur ta sortie du TL081 avec sensibilité aussi grande que possible et tu charges ton alim avec résistance pour 1 ou 2A et condo en // sur la sortie: 100µ...1000µ voire plus. L'alim originale utilise un céramique de 100 pF (C9) pour couper la bande. Si ça oscille tu mets C9 un peu plus grand 220pF, etc.

L'option 2 potards type piste Cermet en série (vs un 10 tours) est bonne, c'est juste que le réglage "gros" peut être un poil trop "touchy"et il y a risque de le tourner rapidement d'un angle un peu trop grand. Mais en tout état de cause METS des résistances de FAIL SAFE (les *R19 et *R20 de mon schéma) et modifie la résistance de tête du potard I_lim (sur mon schéma c'est R6 passée de 56K à 27K), d'autant plus que la connexion sur le PCB se fait par une prise JST-XH3 qui pourrait ne pas être bien enfichée et alors là, ça peut faire BOUM ! J'ai pas mal de ces potards verts chinois, j'ai pas eu de pb ...par contre des faux Bourns, oui j'en ai eu 2 sur 3 utilisés qui m'ont rapidement lâchés... Bullshit !

L'option coupure de la tension de sortie par switch ou relais ne me plaît pas car cette coupure se fait hors de la boucle de régulation et un très bon relais ou un excellent switch, c'est pas donné... Pour le SHORT en sortie pour régler le I_lim, je fais quasiment jamais ça à cause de ce fameux 1000µF qui va se faire décharger violemment et c'est du bon condo, à faible ESR comme je l'ai écrit et donc pas donné. Comment je fais alors ? Je procède différemment:  je règle d'abord ma tension de sortie à la valeur prévue, je commence par mettre  I_lim au minimum (je sais que c'est environ 20 mA), je branche mon montage et j'augmente alors I_lim en regardant V et I sur la face avant. Si je reste en limitation de courant "trop longtemps", je soupçonne un pb et je diagnostique... Bien sûr j'ai une petite idée au préalable du courant attendu (une petite carte avec que quelques CMOS ça va pas consommer  2A  ;) ) et si il y a beaucoup de condos, je sais qu'il va falloir les charger donc j'y vais lentement.

Quand tu testeras l'OverCurrent publie les relevés comme tu l'as fait hier. Ca devrait être édifiant...

Modestie mise à part, je suis effectivement très satisfait de mes PCBs (Je décris sur un autre fil qq règles que je me suis fixées:
http://forum.bidouilleur.ca/index.php?topic=504.msg2937#msg2937 posté le 9 juin 19). Tu auras sans doute remarqué qu'il y a deux plans de masse rectangulaires différents: un pour le 0V non régulé et un autre, plus grand pour le 0V régulé. Sur la face du haut j'ai tous les gros composants et les connecteurs et sur la face du dessous: les pistes, les traversants et les SMD. Les résistances de "puissance" SMD de 1W ont même droit à un bain de pâte thermique sur du cuivre isolé pour dissiper les calories...
J'ai même réussi à n'avoir qu'un seul strap (fil jaune à côté de la sonde du scope) qui passe du côté plans de masse car (règle n° 1 !) JE NE COUPE JAMAIS UN PLAN DE MASSE ( et aussi parce que faire un double face pour 2 ou 3 pistes... c'est vraiment se faire ch... à cadrer parfaitement les 2 typons face à face ou à faire deux bains de gravure).

Pour les appareils de mesures, voici le site :
https://gwunw.fr.aliexpress.com/store/3223141?spm=a2g0s.9042311.0.0.27426c37aOMe8S
Il y a des frais de port d'environ 3€ qui sont rapidement amortis si tu commandes plusieurs modules. Le packaging pour le transport est nickel (pas de sac poubelle à la BangGood...) et ça arrive vraiment rapidos de Singapour direct sans passer par Londres...
J'ai déjà passé deux commandes chez eux et aujourd'hui tu as un double V+I de 4 digits pour moins de 3€...

A bientôt

Yffig
IP archivée

ksyrium

  • Newbie
  • *
  • Messages: 37
    • Voir le profil
Re : compréhension schéma alimentation de laboratoire et amélioration
« Réponse #54 le: août 13, 2019, 07:17:16 pm »

Mercy Yffig pour tous ces conseils et explications.
Je crois que vais en oublier la moitié vu la profusion d'informations   ;)

J'ai commencé à regarder hier la limitation de courant. Pas évident à faire sur le circuit d'origine car il ni a pas beaucoup de place et le CI est franchement un peu "fouillis". Peut-être rajouter une petite plaque "Veroboad" pour installer le transistor et la résistance...
La modification sur les potentiomètres par contre sera plus facile.

Merci pour le lien sur le appareils de mesures. Quand on trouve un vendeur sérieux en Asie, il faut lui faire de la pub.

Pour ma part, j'achète souvent sur le site "aurora.fr" (Ebay) qui est aussi sérieux et dont le matériel arrive très bien emballé.
Il faut choisir de payer un supplément modique pour le port (vers les 4€) à la validation de la commande et tout est envoyé par Avion. Parfait pour les Arduino ou autres plaquettes.
Réception sous 7 à 10J.
https://www.ebay.fr/str/fraurora


IP archivée

Yffig

  • Jr. Member
  • **
  • Messages: 86
    • Voir le profil
Re : compréhension schéma alimentation de laboratoire et amélioration
« Réponse #55 le: août 13, 2019, 10:24:36 pm »

Bonsoir Ksyrium,

J'ai simplement essayé d'écrire ce que je pense utile concernant cette alim et mes messages resteront sur le forum (du moins, j'espère...) donc tu n'as pas besoin d'apprendre tout par coeur  ;) .
Pour implémenter l'OverCurrent, j'ai eu les mêmes soucis que toi: comment faire ça proprement et de manière fiable ? sachant que j'avais déjà tout percé, tout câblé dans mon boîtier, en particulier les petits radiateurs et leur ventilo. Je n'avais qu'une seule solution: refaire TOUT le PCB aux même dimensions et en profiter pour faire d'autres modifs:
- virer la référence par zener + TL081 et la remplacer par un 317 (en To220 que j'ai plein mes tiroirs) mais un 317 ou TL431 en To92 aurait fait l'affaire,
- le réglage de l'offset du TL081 en Vreg m'a paru superfétatoire, et le virer m'a permis d'utiliser un seul DIP8 avec 2 amp op sur support où je pouvais mettre LT1057 (TL082 amélioré), MC34071 ou NE5532 en bipolaires. J'en profite pour (re)signaler sur ce forum que le modèle SPICE du TL081 (Texas Instruments ) est FAUX lorsque utilisé dans LTSpice (J'ai les preuves !)
- le type qu'a dessiné les pistes du PCB double face d'origine: il est peut être graphiste mais certainement pas électronicien: il ne sait pas ce qu'est une "masse" en étoile... Je peux lui envoyer mon fichier  ;) en PCB Express !

Bon ça c'était mon problème, mais dans ton cas, puisque que tu n'as pas encore pas trop de contraintes mécaniques, effectivement fais un petit veroboard avec la résistance et le NPN, forcément en retirant le 2SD1047 du PCB et ça peut être fait proprement et câblé propre.

J'ai regardé le site que tu recommandes: sans doute très intéressant (99% de satisfaits) mais rien de classé...faut tourner les pages. Là j'ai pas le temps de tout voir mais je regarderais plus en détail.

Bonne soirée.

Yffig
IP archivée

Yffig

  • Jr. Member
  • **
  • Messages: 86
    • Voir le profil
Re : compréhension schéma alimentation de laboratoire et amélioration
« Réponse #56 le: août 14, 2019, 09:30:54 am »

Bonjour,
Un complément: quand tu modifieras ton PCB pour y ajouter l'OverCurrent, profites en pour ajouter une diode de protection 1N400x en // sur le transistor ballast.

!! Attention !! J'ai fait une erreur sur mon schéma concernant la valeur de *R19, la résistance de "fail safe" pour le réglage de la tension régulé . elle vaut 1K (0.5w pour dissiper 0.1w quand Vreg est au max ).
J'avais simulé avec Desmos (https://www.desmos.com/calculator) l'effet sur l'évolution de la tension (en %) de V max en sortie avec la fail safe (pour un ratio Potard linéaire de 5K / Résistance de fail safe de 1K) (=> courbe rouge) et ce qui se passerait si le point froid du potard venait à se séparer de la masse (=> courbe violette). La courbe bleue est la courbe originelle du potard, la ligne plane à 1 est le cas Vreg sans fail safe en cas de défaut, donc Vreg est passée à Vmax !.
La courbe rouge te montre que, en bas de l'échelle des tensions, la résistance de fail safe permet un réglage plus fin (à contrario, en haut c'est plus grossier). La courbe violette te montre que, en bas de l'échelle ta tension de sortie ne dépassera guère 5v en cas de défaut.
C'est très facile avec Desmos d'avoir le ratio Potard/Fail Safe mis sous la forme d'un curseur linéaire qui se déplace avec la souris. Par exemple si tu veux que la tension de sortie en cas de défaut ne dépasse jamais 3v, il faut un ratio de 10 donc une fail safe de 500 ohms (et de plutôt 1W) avec une forte dilatation du bas de l'échelle des tensions. Ca peut être très intéressant pour des bidouilleurs qui ne travaillent que sous 3.3v...5V.

Bonne journée.
IP archivée

ksyrium

  • Newbie
  • *
  • Messages: 37
    • Voir le profil
Re : compréhension schéma alimentation de laboratoire et amélioration
« Réponse #57 le: août 19, 2019, 04:36:22 am »

Bonjour,

Quelques nouvelles du projet d'alimentation.

J'ai regardé pour la modification overcurrent, mais franchement vu comme est fait le CI ce n'est pas gagné. Difficile de couper, rajouter et garder aussi une taille suffisante de pistes et fils pour passer 2A. La modification est en passe de tomber aux oubliettes. Je ne me fais pas non plus trop de soucis, n'ayant jamais réussi à cramer un transistor de sortie malgré quelques essais en CC...
Je suis en train de terminer les modifications de résistances pour avoir un 0/100% de réglage aux potentiomètres totalement fonctionnel et sans zone morte.
L'alimentation sortira donc du 2x20.1V sous 2.1A.
J'ai donc aussi limité le courant de sortie pour garder la puissance de celle d'origine et ne pas risquer de détériorer les transformateur. 17V x 2.5A soit 42,5W pour l'ancienne et 20.4 x 2.1A soit 42.8W pour la nouvelle.
Voila, ça avance doucement et le plus dur reste à faire, l'intégration dans le coffret, les modifications d'alimentations, des d'afficheurs, des fusibles...
IP archivée

Yffig

  • Jr. Member
  • **
  • Messages: 86
    • Voir le profil
Re : compréhension schéma alimentation de laboratoire et amélioration
« Réponse #58 le: août 19, 2019, 08:28:38 pm »

Bonsoir Ksyrium et Cécile,
1-Effectivement j'avais aussi réfléchi à la mise en place de l'OCP sur le PCB chinois et j'y avais renoncé pour ma part, non pas que cela aurait été impossible mais c'est parce que j'avais trop de contraintes: radiateur et ventilo, taille du boitier, etc...ce que tu n'as pas (encore?). Et pi, comme j'aime concevoir des circuits et réaliser des PCB, perso, j'ai préféré refaire à dimensions idem la circuiterie en appliquant les règles de l'art. Nota: quand tu vois "ses"pistes pour le circuit 3 A...tu prends pas de risque à câbler en 1mm² (soit ~1mm de diamètre pour 2 A , en plus ces liaisons sont à l'intérieur de la boucle d'asservissement donc compensées automatiquement si tant est que qq 0.1 ohms pourraient te gêner.
2-Une remarque cependant si tu omets de mettre en place l'OCP: je peux me tromper mais tu n'as jamais fait de vrai court jus en sortie. Avec 0.47 ohms tu montes à 16 A, imagine alors avec 10 milli Ohms...
Enfin, c'est toi le décisionnaire. Avec un gros radiateur, il est possible que le shoot de courant soit mieux absorbé.
3-Comme tu dis, le plus dur reste à faire: finir proprement un projet avec câblage, face avant et boitier. Tout le monde n'a pas une CNC comme Cyrob (j'ai pas non plus... juste perceuse, scie à métaux, limes, huile de coude et surtout l'absence d'impatience: pas le droit de rater une étape !).

Je pense que mon topo concernant l'Over Voltage Protection est pas très clair et je reviens dessus.
Ce que j'avais constaté, c'est qu'un potard 10 tours de mauvaise qualité (ce pourrait être un mauvais contact sur le connecteur JST-XH3 qui relie le portard à la carte) peut mettre la tension de sortie à Vmax (environ 30v dans mon cas => destruction très probable du circuit alimenté.
La solution que j'ai implémentée "en urgence", et qui me permettait donc de ne pas refaire un nouveau PCB, est d'ajouter une résistance de valeur faible (par rapport au potard) entre le curseur et le 0v directement sur la carte.
Rémi Maillard de SONELEC.com a fait une page sur ce procédé pour modifier le comportement d'un potard:
https://www.sonelec-musique.com/electronique_theorie_potentiometre_modif_courbe.html
Son objectif est de transformer la courbe de variation d'un potard linéaire en qq chose s'approchant d'un potard log.
Dans mon cas c'est un "effet collatéral" mais surtout pas l'objectif cherché.
Les graphes que je fournis sont:
-les courbes rouges qui sont là pour info: modification de la "linéarité" du potard
-les courbes importantes sont les violettes: quelle sera la fraction de tension en sortie si d'aventure le retour à 0v du potard venait à lâcher.
Je peux fournir les formules à implémenter dans Desmos mais ça dépasse pas le théorème de Thévenin...

La solution que j'ai implémentée n'est donc pas vraiment la meilleure...Mais elle marche !
J'avais à l'époque réfléchi à une VRAIE solution pour ce problème d'OVP: je la décris dans le schéma joint et je fournis la simulation SPICE correspondante
nota:
1-Le schéma sous ExpressPCB n'accepte pas les caractères accentués => les explications sont en anglais, sorry...
2- La simulation SPICE a été faite avec un petit MosFet BS170 que j'ai intégré dans SPICE iV à l'époque. Elle est parfaite !
Spice XVII a un petit mosfet 2N7002 en standard...je l'ai testé avant de rédiger ce post => Le MOSFet ne se sature pas ça, ça mérite un peu de "tunning" (résistances, diode zener...)
3- Je n'ai pas réalisé de maquette sur breadbord pour valider. Si je devais implémenter cette solution, je ferais obligatoirement une maquette avec les composants que je vais utiliser sur le PCB final.

Et enfin, un dernier point intéressant:
Cécile avait soumis à la sagacité des bidouilleurs le schéma (aujourd'hui disparu...) de Ian Johnston qui présente une pré-régulation avec LM2576-ADJ.
L'idée de réduire drastiquement la dissipation d'une alim linéaire en asservissant un pré-régulateur à découpage m'a vivement intéressé: qu'attendre d'une telle approche en matière de bruit en particulier ?
J'ai alors commandé un lot de ces petits step down à 0.60€ pièce (!) munis d'un LM2596 (fakes !) que Bertrand et Cyrob ont aussi essayé. Vraiment pas terribles... les 3A : jamais de la vie ! mais pour un step down réglable jusqu'à 2A, ça peut le faire éventuellement...
Cyrob les utilise dans une approche de pré-régulation très intéressante via un optocoupleur dont la non linéarité est apparemment mise à profit pour réduire la dissipation de la partie linéaire à 5v de drop out ce qui donnerait 15W si 3A sur la linéaire. De plus la limitation 3A est intégrée dans les LM25x6 (x=7 ou 9).
Ces circuits existent en boîtier TO220 et ont une efficacité proche de 80%...
Mon fournisseur préféré (Reichelt) propose le 2576 à 1.11€ et le 2596 à 3€. Je suis en train de finir l'analyse des datasheet et grâce au Webench de Texas Instruments le choix des composants avec pour objectif de réaliser qq maquettes très propres avec ces circuits. Je vous tiendrais au courant...
réf. Bertrand: https://www.youtube.com/watch?v=ODPycAvBsbI
réf. Cyrob: https://www.youtube.com/watch?v=t23jyYzn3A4

Bonne soirée

Yffig
IP archivée