Forum Électro-Bidouilleur

Merci de vous connecter ou de vous inscrire.

Connexion avec identifiant, mot de passe et durée de la session
Recherche avancée  

Nouvelles:

Bienvenue au Forum de discussion Électro-Bidouilleur! Inscrivez-vous pour participer aux discussions!: 
http://forum.bidouilleur.ca/index.php?action=register Les demandes d'inscription sont révisées quotidiennement.

Auteur Sujet: [Résolu] Oscilloscope Siglent SDS1202X-E : problème sur la voie 1  (Lu 877 fois)

Yffig

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 613
    • Voir le profil
Re : Oscilloscope Siglent SDS1202X-E : problème sur la voie 1
« Réponse #15 le: mai 03, 2020, 10:28:00 pm »

@ Dolu,
J'avais interprété ton smiley au 3° degré... J'ai travaillé pas mal de temps avec des allemands et je sais ce qu'ils peuvent être insupportables de "suffisance" (le pan-germanisme, c'est pas une légende) et c'est pas près de changer mais c'est une autre histoire. Pour ce matos, ils sont bons, très bons même: reste t il un seul constructeur français de matos de mesure digne de ce nom ? NON ! Donc...
Allez bonne nuit et à bientôt !
Yffig
IP archivée

Électro-Bidouilleur

  • Administrator
  • Hero Member
  • *****
  • Messages: 748
  • C'est moi le boss!
    • Voir le profil
    • Site Web Électro-Bidouilleur
Re : Oscilloscope Siglent SDS1202X-E : problème sur la voie 1
« Réponse #16 le: mai 03, 2020, 11:02:25 pm »

@ Yffig Bah, pas de soucis. C'est assez difficile de se faire comprendre par écrit. Et le ton est extrêmement difficile à transmettre, malgré les smileys. Et moi j'ai tendance à lire et à répondre trop vite!

J'avais oublié de mentionner, j'ai refait le test avec un atténuateur de 20dB, question de garantir un impédance de 50 ohms à l'ampli dans les deux situations. Mêmes résultats.
IP archivée

Yffig

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 613
    • Voir le profil
Re : Oscilloscope Siglent SDS1202X-E : problème sur la voie 1
« Réponse #17 le: mai 04, 2020, 10:11:16 am »

@ Bertrand en particulier,

J'ai donc fait ce matin qq simulations avec le .s2p de l'ERA-21 fourni par Mini-Circuits sur 50 à 500 MHz.
- L'ERA- 2 seul avec atténuateur 10 dB est quasi  "flat": normal.
- L'ERA- 2  avec atténuateur 10 dB (non adapté !) attaquant une Hi-Z de 1MΩ // 20 pF chute de 6.27dB à 300 MHz (50 MHz = 11.94 dB, 300 MHz = 5.67 dB)
- Nota: un coax RG58 de 2 m attaquant Hi-Z du scope directement n'a pas un comportement différent: chute de 6.6 dB à 300 MHz (6.02 dB à 50 Mhz et -0.58 dB à 300 Mhz). Dans ma simulation, c'est plutôt attendu: le condo // de 20 pF voit une impédance de source de 50 Ω si coax direct et environ 50.1 Ω (calculés à la main !) avec l'atténuateur non adapté... On ne pourrait pas faire plus semblable...et 50Ω série 20 pF donne bien une Fc à -3db de 160 MHz, d'où les -6dB au moins à 300 MHz.
Par contre la Hi-Z se voit parfaitement sur le S11 : quasiment aucune puissance d'absorbé dans le cas du coax direct... tout est réfléchi vers la source qui, elle, va absorber complètement (ou presque) cette onde réfléchie puisqu'elle est délibérément et parfaitement de  50 Ω .

Peux tu faire ce test en direct sur ton Agilent comme hier (une simulation reste une simulation...) ?.

Bien sûr, aucune de ces simulations ne prend en compte la BW du scope lui même (conformément à la formule page 9 du papier de R&S).

1: j’utilise plus volontiers le PGA-103 de Mini-Circuits aussi (moins de gain, moins de BW mais quel NF !(malheureusement je ne sais pas le mesurer correctement (pas de source de bruit étalonnée et mesurer +0.6 dB à des niveaux très faibles genre -140 dBm n'est pas dans les specs de mon matos...).

Bon réveil !
(PS: j'avais oublié les PJ  :-[ )

Yffig
« Modifié: mai 04, 2020, 01:17:09 pm par Yffig »
IP archivée

loulou31

  • Full Member
  • ***
  • Messages: 187
    • Voir le profil
Re : Oscilloscope Siglent SDS1202X-E : problème sur la voie 1
« Réponse #18 le: mai 04, 2020, 03:58:56 pm »

Bonjour Yffig,

Je viens de voir ta simulation avec et sans 50 Ohms sur l'oscillo qui est interessante.
En fait quand tu as 50 Ohms tu as aussi la capa d'entrée de l'oscillo qui ne disparait pas par enchantement car elle correspond à la capa physique de l'atténuateur d'entrée plus les connexions. Selon où est placée la charge de 50Ohms dans l'oscillo cette capacité peut être un peu plus faible mais ne disparait pas. Il serait intéressant de faire une mesure d'impédance d'entrée de l'oscillo avec un VNA avec et sans 50 Ohms pour voir cette fameuse capa de 20pF.

Ceci dit l'oscillo de Dolu semble bien avoir un problème, malgré ses mesures pas très rigoureuses  à moins qu'il y ait un problème caché logiciel....

Jean-Louis
IP archivée

Yffig

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 613
    • Voir le profil
Re : Oscilloscope Siglent SDS1202X-E : problème sur la voie 1
« Réponse #19 le: mai 04, 2020, 05:56:24 pm »

Bonjour Jean Louis,

Je n'ai pas fait de simulation (ni de test) avec une entrée 50 Ω, l'objectif était de regarder le cas d'une entrée Hi-Z (1MΩ // 20 pF comme Bertrand l'avait fait). La seule simulation faite en 50 Ω est celle qui vérifie la BW de l'ERA-2 telle que fournie par Mini-Circuits.
Pour les autre simulations, c'est une toujours Hi-Z qui charge soit:
- l'atténuateur après le MMIC ( l'ampli op isole du port 2 qui est forcément en 50 Ω pour la mesure du S21)
- la ligne de 2 mètres (ici encore, l'ampli op isole du port 2 qui est forcément en 50 Ω pour la mesure du S21)
J'ai précisé dans mes posts précédents que je n'aime pas le Té avec bouchon 50 Ω sur une entrée Hi-Z (justement parce que ça ne supprime pas la capa // et même ça en rajoute un poil... la partie du Té non utilisée).
Quand j'ai besoin d'une entrée 50Ω native, j'exhume mon vieux LeCroy 500 MHz que j'utilise uniquement en mode 50Ω et qui est spécifié:
- 1MΩ // 15 pF
ou
- 50 Ω , 1% sans indication d'une capa// .
J'avais fait en 2013 avec mon 1er VNA une mesure de cette entrée mais jusqu'à 200 MHz seulement (max du miniVNA-Pro): 2.58pF // 49.57 Ω (cf PJ),  ce qui donnerait, sous 50 Ω, une BW sur l'entrée de 1.2 GHz (plutôt 2.4 GHz si on met les 2x 50 Ω en //), donc très peu d'influence jusqu'à mes 500 MHz de BW spécifiée poour le scope.
Bien sûr je pourrais passer un coup de VNWA-3 ( 500 Mhz sans pb) sur cette entrée en mode 50Ω  mais pour , l'instant je l'ai rangé le Lecroy dans son placard (c'est lourd et encombrant, je ne le laisse pas sur mon WorkBench en permanence. Mais j'y penserai à l'occasion quand je le sortirai.

A plus
Yffig
« Modifié: mai 04, 2020, 06:47:11 pm par Yffig »
IP archivée

loulou31

  • Full Member
  • ***
  • Messages: 187
    • Voir le profil
Re : Oscilloscope Siglent SDS1202X-E : problème sur la voie 1
« Réponse #20 le: mai 05, 2020, 09:53:01 am »

Bonjour Yffig,

Interessant la mesure de l'impedance en 50 Ohms, et les 2.5 pF mesurés sur l'oscillo. Ca voudrait dire qu'en 50 Ohms l'atténuateur haute impédance de l'oscillo n'est plus utilisé au profit d'un atténuateur RF  50ohms. En fait ce n'est pas juste une 50 Ohms mise en // sur l'entrée comme je le pensais : il y a deux chaines d'atténuation dans l'oscillo : une en haute impédance : 1 MOhms et une 5à Ohms.

En fait moi je préfére laisser l'oscillo en haute impédance et mettre une charge de passage, car j'ai un seul oscillo avec cette possibilité ( un vieux Lecroy aussi mais 400MHz) et je préfére éviter de détruire la charge 50 Ohms de l'oscillo. En fait par rapport à tes mesures  il semblerait que ça soit préférable d'utiliser l'oscillo en conf 50 Ohms. Les mesures de Bertrand semblent aussi aller dans ce sens.

Pour les sondes attention : si on utilise une sonde 200MHz avec un oscillo 200MHz la bande passante de mesure ne fait plus que 140MHz.....Comme quoi pas la peine de d'investir dans un oscillo de bande passante élevée si on veut faire des mesures incircuit avec des sondes passives.

Jean-Louis

Jean-Louis
IP archivée

Yffig

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 613
    • Voir le profil
Re : Oscilloscope Siglent SDS1202X-E : problème sur la voie 1
« Réponse #21 le: mai 05, 2020, 10:01:35 pm »

Bonsoir Jean Louis,

Merci pour ce retour.

-Plutôt que de donner des valeurs déjà calculées quand il s'agit de connaître la BW (sonde + scope), j'ai préféré renvoyer par 2 fois dans mes messages précédents, le lecteur à la page 9 du doc R&S que j'ai mis en lien... ("si tu donnes un poisson..., apprends lui plutôt à pêcher"...tout le monde connaît cette formule que l'on attribue aux Chinois).

- Sur des scopes à entrées exclusivement Hi-Z (1MΩ // 20 ou 30 pF), y'a pas photo: la BW maximale est obtenue en mode sonde X10.  La sonde en mode x1, en ce qui me concerne, c'est si vraiment j'ai besoin de sensibilité (et encore je préfère utiliser un Analyseur de Spectre pour mesurer, par exemple, un spectre de distorsion en audio, j'ai pas la phase mais à ce moment là je n'en ai pas besoin). Il m'arrive, bien sûr, d’utiliser un simple coax si je suis sûr que mon impédance de source est faible. Voilà donc décrite une synthèse de mes bonnes pratiques et je n'en changerai pas, je suis sûr de ce qu'elles valent.

-La méthode du Té+ bouchon 50Ω (ou de la terminaison coaxiale 50Ω (que je n'ai pas)) sur une entrée Hi-Z: je n'aime vraiment pas !  Bien sûr à défaut de mieux, c'est jouable mais il faut avoir conscience que c'est très loin d'être parfait. Voici en PJ les mesures que j'avais faites au VNA de 10 MHz à 200 MHz, dans ce cas sur un PicoScope de BW annoncée 200 MHz, à entrée Hi-Z exclusivement:
- à 10 MHz, c'est 49.25Ω // 16.65 pF, OK c'est utilisable...
- à 200 MHz, c'est 26.86Ω // 10.28 pF... là c'est NON ! La partie résistive est partie en sucette..... Je ne saurais en expliquer la cause, j'en conclus simplement que "Faut pas faire comme ça !"

-Alors venons-en à la bonne méthode: le scope à entrée native 50 Ω et entrons un peu plus dans les détails, là où se cache le diable...:
J'ai acquis d'occaze pour cela sur eBay, il y a 10 ans, un Lecroy 9354A (parce que j'avais trouvé le Service Manual en scan (un peu pourri mais vaut mieux ça que pas de SM du tout ;)). J'ai eu avec une sonde d'origine la PP002.

Pour moi il était évident qu'une entrée native 50 Ω sur un scope spécifié 500 MHz c'était le TOP ! même si le SM ne donnait pas la capa // sur cette entrée (c'est pourquoi, dès le premier VNA que j'ai eu dans ma vie, je me suis empressé de la mesurer --> 200 MHz). Cette mesure m'a absolument convaincu que j'avais eu raison de mettre quelques 800 € dans ce matos un peu brinquebalant ( écran à moitié brulé d'être resté allumé quasiment toute sa vie, coque en plastique un peu déglinguée (c'est pour ça que je ne le sors de son placard que très rarement, uniquement quand j'en ai vraiment besoin).
Enfin une vraie entrée 50 Ω avec très peu de capa // !

Grâce au SM (et j'espère que tu as trouvé celui du tien), je peux entrer dans quelques détails supplémentaires très intéressants:
- En mode Hi-Z, la BW n'est que de 250 MHz, tiens...
- La commutation entre Hi-Z et 50 Ω se fait par relais RF (nécessaires par ailleurs pour le mode auto calibration des entrées)
- La résistance d'entrée 50 Ω supporte 1W (+30 dBm) pendant 17s, la température de la résistance est supervisée et déclenche le passage en OverVoltage et coupe les relais d'entrée (je n'ai pas un seul équipement genre SA, VNA qui supporterait ces +30 dBm, j'ai donc  l'habitude de l'atténuateur sytématiquement placé en entrée du matos 50 Ω, j'ai eu d'occaze sur eBay un Weinschel 6 à 66 dB continuement réglable DC-6 GHz, de 5W (+37 dBm soit ~16 Vrms, je suis donc tranquilou).
Ceci pour te dire que ton Lecroy si ça se trouve est dans les mêmes specs en entrée
-Concernant les atténuateurs / amplis en interne. Je ne peux te dire si il existe deux chaînes différentes Hi-Z et  50 Ω: apparement ce boulot est fait par un chip custom MFE409, datasheet introuvable.

-En cherchant bien dans le SM on trouve les infos suivantes... pour les BW, elles dépendent du niveau donc j'imagine du gain des amplis internes...:
- 500 MHz pour Vin ≥ 200 mV/div
- 400 MHz pour 200mV> Vin ≥ 100 mV/div
- 350 MHz pour Vin < 100 mV/div.
Donc les 500 MHz, c'est pas du "tout cuit"...

En plus la sonde standard PP002 est une sonde uniquement 10:1 de 350 MHz  10MΩ // 14 pF.
Bref, la vraie BW... ellle est où ?
Le calcul de la BW avec sonde 10:1 à Vin  ≥ 200 mV/div donne 287 MHz.... (Faudra que je pense à la mesurer quand je le ressortirais ainsi que Zin en mode 50 Ω), au pire de 250 MHz pour Vin < 100 mV/div.

En option à l'époque, il y avait une sonde PP062 10:1 de 1 Ghz mais 500Ω... là, la BW réelle à Vin  ≥ 200 mV/div serait de 450 MHz. On s'approche des 500 MHz marketés.

Fallait lire the F.. Manual pour le savoir !

Bonne soirée !

Yffig


« Modifié: mai 05, 2020, 10:06:17 pm par Yffig »
IP archivée

loulou31

  • Full Member
  • ***
  • Messages: 187
    • Voir le profil
Re : Oscilloscope Siglent SDS1202X-E : problème sur la voie 1
« Réponse #22 le: mai 06, 2020, 08:28:35 am »

Bonjour Yfiig,

J'ai un 9310A acheté aussi en occasion sur Ebay et c'est en effet pareil les 400MHz c'est sur 50 Ohms et sur calibres > 200mV. En high Z c'est 250MHz au bout de la sonde ... mais ils ne disent pas laquelle?
De toutes façons faut pas rêver quand on balade une sonde /10 sur un circuit avec les 10 ou 15 pF ça perturbe la mesure sur des circuits logiques rapide et encore plus en HF. C'est pour ça que les scopes grand public avec des BP au delà de 200MHz à mon avis ç'est un argument marketing....

En HF quoiqu'il arrive soit on fait une mesure de fréquence ou spectre et là on fait par couplage lâche et on ne peut mesurer le niveau. Soit on veut mesurer le niveau et on ne peut le faire en dérivation. Il faut mettre un coupleur ou un atténuateur dans le circuit pour prélever une fraction connue du signal. Il y a aussi la solution des sondes actives HF, j'ai utilisé en pro, mais il faut une très bonne sonde et en plus pas mal de précautions d'utilisations pour éviter les perturbations sur le circuit.

Jean-Louis
IP archivée

Dolu

  • Newbie
  • *
  • Messages: 9
    • Voir le profil
Re : Oscilloscope Siglent SDS1202X-E : problème sur la voie 1
« Réponse #23 le: mai 09, 2020, 01:17:07 pm »

Bonjour,

Je ne pensais pas que mon petit souci d'oscillo, susciterait autant de discussion.
Vous m'en voyez ravi :)

Si vous me le permettez, je reviens sur le sujet de départ.
J'avais en effet promis de faire part de mon expérience avec le SAV Siglent.

Pour le moment tout se passe bien.
J'ai obtenu une réponse assez rapide et en quelques échanges par mail, on m'invite à renvoyer mon appareil. On me dit également que le problème est couvert pas la garantie (avant même l'examen de l'appareil et sans cherchez la petite bête sur mes tests peu rigoureux).
Le colis est parti ce matin pour l’Allemagne.

A suivre...

Une bonne journée à tous.
IP archivée

Électro-Bidouilleur

  • Administrator
  • Hero Member
  • *****
  • Messages: 748
  • C'est moi le boss!
    • Voir le profil
    • Site Web Électro-Bidouilleur
Re : Oscilloscope Siglent SDS1202X-E : problème sur la voie 1
« Réponse #24 le: mai 14, 2020, 01:40:40 am »

@Yffig Vieux motard que jamais!

Voici les résultats de mesure de l'ampli ERA-2 sur l'Oscilloscope Agilent MSO6034A. Toutes les mesures sont en milli-Volts. J'ai peut-être saturé le ERA-2 dans les fréquences les plus basses et à haute impédance. Je te laisse faire l'analyse qui t'interpelle le plus! Le fichier XLS est annexé.

S'il y a quoi que ce soit d'autre que tu voudrais que je mesure, mes branchements pour ces mesures sont toujours faits.
IP archivée

Yffig

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 613
    • Voir le profil
Re : Oscilloscope Siglent SDS1202X-E : problème sur la voie 1
« Réponse #25 le: mai 14, 2020, 08:01:59 pm »

Bonsoir Big Boss !

Tout d'abord merci de t'être décarcassé pour faire ces mesures  ;)
Ici, la contrepèterie est assez souvent modifiée en "Vieux motard que j'aimais" mais alors ce n'est plus vraiment une contrepèterie...

J'ai utilisé tes mesures pour confirmer qu'en tout état de cause mesurer directement sur une entrée 50 Ω était de loin la meilleure façon de procéder comme nous en avons échangé par MP.

J'ai pour chaque type de mesure utilisé la valeur lue à 10 MHz comme 0 dB: cf les PJ.
Y'a pas photo... c'est bien la mesure directe en 50 Ω qui gagne le concours de "flatitude" avec une BW de 320 MHz à -3 dB. L'utilisation d'un MMIC n'arrange rien, bien au contraire

Encore merci pour ces mesures !

Yffig
IP archivée

Dolu

  • Newbie
  • *
  • Messages: 9
    • Voir le profil
Re : Oscilloscope Siglent SDS1202X-E : problème sur la voie 1
« Réponse #26 le: juin 21, 2020, 10:05:56 pm »

Bonsoir à tous,

Et voilà, c'est fait, j'ai enfin reçu mon oscilloscope :-)

Du coup, je me suis empressé de reproduire le cas de test que je décrivais dans mon premier post.


... et voici le résultat après réparation :



Les deux courbes se superposent, indiquant que les deux entrées "voient" bien la même chose.
Bon... J'ai bien compris que mon setup de test n'est pas franchement rigoureux, mais il m'a semblé que pour que les résultats soient comparables il faillait les obtenir dans les mêmes conditions.

A part cela, j'avais promis de faire un petit retour d'expérience sur le support Siglent.
Je suis globalement très satisfait du service.

Voici les points positifs :
- Mon problème à été très rapidement pris en charge.
- J'ai été pris au sérieux malgré mon amateurisme et je n'ai pas eu besoin de faire des pieds et des mains pour que l'on me propose de faire jouer la garantie.
- Les échanges avec mon interlocuteur, exclusivement en anglais, sont fluides et très détendus.
- C'est la même personne qui a suivi mon dossier du début à la fin (si seulement l'administration Française pouvait prendre ça en exemple...).
- Quand il s'est avéré que le délai d'obtention des composants de remplacement risquaient d'être longs (je mets ça sur le compte du Covid), il m'a été proposé de m'envoyer un autre appareil (d'occasion mais dont on m'a assuré qu'il était comme neuf).

J'ai finalement opté pour l'appareil de remplacement, ce qui m'amène aux points négatifs :
- J'aurais préféré que l'on me propose un appareil neuf.
- L'état de l'appareil reçu est conforme à ce qui m'a été annoncé. Juste un petit défaut : il y a comme un petit bout (1 cm) de poil blanc de pinceau coincé entre l'écran LCD et la vitre de protection. Cela ne gêne en rien l'utilisation de l'appareil et ce n'est quasiment pas visible une fois l'occilo allumé mais je le note car j'attache beaucoup d'importance à l'entretien du matériel.
- Le cordon d'alimentation ne m'est pas revenu avec le nouvel appareil.

Voici une affaire qui se termine plutôt bien, en espérant que ce retour d’expérience soit utile à d'autres.

Bonne fin de soirée à tous,
Ludo
IP archivée

loulou31

  • Full Member
  • ***
  • Messages: 187
    • Voir le profil
Re : [Résolu] Oscilloscope Siglent SDS1202X-E : problème sur la voie 1
« Réponse #27 le: juin 22, 2020, 09:21:24 am »

 Bonjour,

Merci Dolu de nous avoir informé jusqu'au bout de ton histoire de SAV, car souvent ce n'est pas le cas!
La moralité, c'est que dans l'achat d'un appareil le SAV c'est important.
Pour un remplacement avec du neuf, ca se fait uniquement si l'appareil est en défaut lors de sa livraison.
Enfin un conseil, ne pas envoyer en SAV les accessoires à moins que ça soit indispensable. J'ai travaillé au tout début de ma carrier en SAV, et les accessoires c'etait une galére à gérer.
Petite question tu as payé le port pour l'envoyer au SAV ou c'était pris en charge?

Jean-Louis
IP archivée

papyblue

  • Sr. Member
  • ****
  • Messages: 334
    • Voir le profil
Re : [Résolu] Oscilloscope Siglent SDS1202X-E : problème sur la voie 1
« Réponse #28 le: juin 22, 2020, 11:01:02 am »

Bonjour Ludo,

Merci pour ce retour, cela me rassure un peu pour mon achat. Sinon, sache qu'il n'y a pas que les pinceaux qui perdent des poils blancs, personnellement, j'en trouve régulièrement de cette longueur sur mon bureau  ;)

PB
IP archivée

Dolu

  • Newbie
  • *
  • Messages: 9
    • Voir le profil
Re : [Résolu] Oscilloscope Siglent SDS1202X-E : problème sur la voie 1
« Réponse #29 le: juin 22, 2020, 09:30:28 pm »

Bonsoir,

@loulou31 : les frais d'envoi étaient à ma charge. Par contre ils ont pris en charge le retour.

@papyblue : tant qu'il y a des poils qui tombent, c'est bon signe car cela veut dire qu'il en reste ! :D :D
Plus sérieusement, je pense que l'on trouve chez Siglent des produits tout à fait correctes (pour autant que je sois capable de juger) pour un amateur qui veut bricoler dans de bonnes conditions. Enfin c'est mon avis d'amateur... très amateur.

Bonne fin de soirée,
Ludo
IP archivée