Forum Électro-Bidouilleur

Merci de vous connecter ou de vous inscrire.

Connexion avec identifiant, mot de passe et durée de la session
Recherche avancée  

Nouvelles:

Le Forum est maintenant chiffré (préambule https). Bien sûr, des liens externes insérés dans les sujets vont demeurer inchangés. Mais la composition des pages du Forum est désormais sécurisée. Si des probèmes d'affichage surviennent, veillez à vider votre cache pour ce site.

Voir les contributions

Cette section vous permet de consulter les contributions (messages, sujets et fichiers joints) d'un utilisateur. Vous ne pourrez voir que les contributions des zones auxquelles vous avez accès.

Messages - francoisp31

Pages: [1] 2 3 ... 6
1
Vos projets et Montages d'Électronique / Re : Probléme bluetooth
« le: juillet 26, 2022, 08:16:35 am »
disons que c'est une solution "facile et fiable" à la fois pour ce besoin précis  d'utiliser une antenne directionnelle, voir même à la limite une antenne "ricoré"   si on veut éviter de dépenser des sous

2
Selon tes finances, tu peux déjà commencer par un petit kit très basique autour des 30 euros oui auquel il faudra ajouter un peu de fil semi-rigide style (paire téléphonique serai bien ça peu se récupérer gratuitement souvent)  et une breadboard  au minimum.    ;D

Si tu as un peu plus de moyen, tu suis les recommandations électro-bidouilleur :vidéo #90 et #96  + une breadboard que je trouve toujours aussi pertinent à ce jour, (en fait je fais voir au fablab aux débutant ces vidéos pour les calmer sur leurs envies d'achats) ; et du fil   là tu peux déjà faire pas mal de choses voir beaucoup de choses.

Les autres achats utiles il faut les étaler dans le temps au fur & à mesure de ses besoins et de sa progression.

Mais ne dépenses pas tout de suite plus de 60/70€ ou $  ce serait des achats qui resteront en boite plusieurs semaines/mois avant d’être utilisés.  ;D

;)

tu compléteras ta collection de composants tout doucement après. Mais attention le hobby devient vite addictif et la progression est assez rapide, il faut s'attendre à pratiquer +ou- régulièrement "à vie" heureusement ce n'est pas chère tant qu'on n'a pas besoin d'équipements d'instrumentation de haute précision/justesse.   :)
 
une autre vidéo que j'ai pour aider des débutant à acheter que de l'utile https://www.youtube.com/watch?v=jKxUZyCqd-0



3
ça se fait oui c'est panelizing je crois le terme dans les moteurs de recherches il y a des tutos notament en vidéo youtube anglophones, doit y avoir aussi en français

j'avais réussi en suivant celle là par exemple https://www.youtube.com/watch?v=n-PufDKrF_o

4
ok mais pour l'affichage des secondes utiliser/piloter  du néopixel  (60 leds donc) n'utiliserai qu'un seul connecteur coté ESP par exemple

pour faire du 7segment géant soit utiliser des drivers BCD -> 7segment  soit réaliser les segments soit même  effectivement  mais là aussi ça limite le nombre de connections  au lieu de faire les segments comme ça
ça fait du coup 4*4 connections (16 donc)   seulement

c'est pour ça que les 89 sorties je voyais pas l'interet et encrore utiliser les segments construits soit même peu aussi se limiter en codant plus par seulement 4 connections  si on fait une serie de neopixels  pour faire les segments aussi. 

bref ...   c'est vraiment une question de choix mais je trouve ta solution complexe pour le resultat voulu :)   surtout si tu souhaitais faire aussi des temperatures/%humidité/pressions etc...

si ça peut t'aider à voir ce que je veux dire https://gitlab.com/goblinrieur/signed-led-panel  j'ai prototypé ça il y a peu

5
autant d'entrées/sorties me semble abhérant  es tu sur d'avoir besoin d'autant ?
où j'ai pas compris ton concept; pour avoir déjà fait une station météo qui avait dans un coin une horloge  j'avais réussi à tout faire avec beaucoup moins d'éléments
pourrais tu faire un diagramme bloc de ta logique et besoin, on pourra peut etre t'aider à simplifier et solutionner ta liste de besoin comme première étape

6
Discussion Générale d'Électronique / Re : TM1637 5v et esp 3.3v
« le: juin 20, 2022, 09:52:08 am »
peux tu faire peut etre un schéma block ou quelque chose j'avoue ne pas bien saisir ton besoin ducoup
parce que pour mois je le vois toujours comme un simple changement de niveau de tension sur le bus  à un moment de son circuit "fonctionnel/rôle"

8
aussi dans le doute est ce que c'est pas une difference USB3.X vs USB2 ??

9
déjà la première question qui me vient c'est que tu compares sur 4 machines différentes donc 4 configs différentes, donc tu auras un potentiel de 4 comportements différents.
là tu en a trouvé 2 si j'ai bien compris.

donc déjà il faut vérifier surtout sur les portables où c'est souvent le cas pour économiser de la batterie, si les ports USB sont bien TOUS actifs mais aussi en permanence et pas juste quand le PC est sur secteur. (dans le basic input output setup) .

Parceque coté arduino ça semble ok , ça me semble la première chose à vérifier. (ça veut pas dire que c'est forcément ça mais c'est déjà un doute à lever).

10
pas mal du tout ce projet :)

11
J'ai fini par trouvé d'autres diodes de protection en défaut et trois ou quatre capa un peu douteuses.
malgré ça et la reprise de 3/4 soudures  qui semblaient faibles,
je me trouve dans une situation où l'appareil pourrai marcher sauf que la calibration est hors des limites des potentiomètres dédiés à cet usage, vers le haut s'aurait pu être remplacé par une valeur supérieure
mais vers le bas en revanche pas vraiment. de plus certains signaux qui devraient être précis à 10khz sont plus autour des 8 et les signaux internes à 100khz étaient plutôt autour des 92.
J'ai donc abandonné ce projet et rapporté l'appareil à l'association. il servira au moins de façade en attendant.

12
tout à fait,  c'est pour ça que je ne desespère pas de finir l'exercice, sachant qu'au pire j'aurai appris quelques trucs de méthodologie :)

13
bon, la calibration n'a pas donné grand-chose, le range de valeur juste sur les résistances a presque doublé ; en revanche sur les mesures de tension j'ai rien de mieux.
je vais donc reprendre l'analyse des cartes, et voir si je trouve des défaillances de composants , mais avec mons d'espoir.

la conception c'est quand même beaucoup plus facile que la réparation :)


On me glisse dans l'oreillette : tester les Q7/Q1/Q3/Q2/Q4 +les alims U5 & U2  ainsi que les U7 à U10    si  la moitié de tout ça est douteux ou grillé, on est à peu pres sur que les cartes filles ont des composants en défaut chacune....  ça devient compliqué. parce que U7 à u10 (des MCT2E sont tous en defaut les 2 lm339 aussi

je crois que ça va être encore long... je vais tenter encore 2/3 choses mais sinon ça finira au recyclage et la facade en tableau

14
Les mesures de resistances ne fonctionne pas bien non plus,  ce n'est juste qu'autour des valeurs entrre 2k et 200k  tout le reste affiche n'importe quoi même des valeur négatives.
j'ai aussi trouvé sur la carte mère, du fond de panier deux diodes HS que j'ai remplacées.

je vais continuer un peu à chercher   de ce coté là, et sur les 4 cartes filles aussi si il y a des compostans HS.

si je n'en trouve pas je tenterai la procédure de calibration , ça à l'air très long et casse pied, mais bon ...  au pire ça ne change rien. au mieux ça résoud une partie des problèmes.

15
nouvel état des choses :
 
les capacités C3/C4 étaient BONS

la capacité C10 étaient KO j'avais en stock

la capacité C12 étaient KO j'avais en stock

le régulateur VR2 était KO  (7815 classique)

Maintenant que j'ai le +15V et le -15V, l'appareil ne s'allume pas, on entend juste le relais coller, mais aucun affichage, ni diode de façade disponible.
Après un contrôle des soudures et des pistes, une piste était commune face du dessous/face du dessus

Donc j'ai ajouté la soudure sur la face du dessus manquante.
A présent l'appareil pourrait marcher

Sauf qu'il affiche n'importe quoi +1999.9 volts par défaut à vide. Et si je fais  une mesure de pile 9v (mesuré à 8.992 sur un autre multi)  donne -5.632volts

Prochaine étape chercher si il y a d'autres défauts, d'autres composants qui pourraient être embêtant.

Pages: [1] 2 3 ... 6